Continuously high load on Hassbian installation

I have been using Hassbian for a little over a year now, and everything has worked very good. I chose to install Hassbian instead of because I needed additional software on the Raspberry Pi 3 (OpenVPN, InfluxDB and Grafana).

The last couple of weeks, Hassbian has been slow and laggy. I checked the load on the machine, and the load is continuously high load of 5 the last 15 minutes, and up to load of 7 for the last minute. Restart didn’t resolve the issue, and I have checked which processes that uses alot of CPU.

InfluxDB has been taking a lot of CPU power, so I tried uninstalling it (I didn’t use it anyways), but the load is still high. The Home Assistant processes doesn’t use alot of resources.

I don’t have any custom components or special setup. I have deCONZ, RFXCOM and Aeotec Z-stick Gen 5.

Anyone experienced the same, or know where I should start to debug?

A failing drive can be the cause of that - the system constantly trying to save to a dud disk (or sd card in this case)

Try the dmesg command, it may show something.

Any way to save the SD card? Take it out and make an image backup?

backups of your setup should be a daily process, don’t leave it to chance

Yep, I have some backup of the configuration, but not complete backup for the whole card itself.

I haven’t made a definitive diagnosis, only an educated guess.

It is going to be hard to image a card that is failing.

I think everything you need to keep from a home assistant point of view is in your configuration directory (from memory /home/homeassistant/.homeassistant)

Plug in a usb stick and copy as much as you can.

Thanks @nickrout