Core update 2024.5.4 won't complete

I have tried to update the Core to version 2024.5.4 a few times now and it just spins.
I did a restore of an old snapshot and doesn’t seem to help. Still doing it with Core update 2024.5.5.
The error message is that it doesn’t have a Unique ID.
How can I correct this?

image
image

You’re mixing things here. :slight_smile:

What you see as an “error message” is only a note, that you can’t change things from the UI. That’s all. No worries here.

For the update itself, you should give it some time, if in doubt, just leave it running over night. There sometimes are issues with an update, eg. the internet connection is not good, or the server is not reachable, things like that.

If you don’t get any errors in your log for that update, just let it run and see, if it’s going through.

1 Like

That’s a big jump from 2023.5.2 to 2024.5.5 - lots of changes since last year. Just curious why you have waited so long to apply the updates?

I normally do Core updates as soon as they come out.
But when I tried to do the 2024.5.4 update from 2024.5.3 it was not finishingk.
So I did a restore from a snapshot (HA is installed on a VM) from 2023.5.2.

So last night I let 2024.5.4 run all night and this morning is was still just spinning with no progress.

Is there any way to force or manually install updates?
Or do I need to start over with a new VM install?

thanks, Steve

I would take a backup within HA (not a VM backup) of your current system and then do a fresh install of 2024.5.5 and then restore your backup.

2 Likes