Creating new docker Container (read-only filesystem)

Hi,

i am running HassOS on freshly installed Raspberry Pi 3. I installed the Addon Portainer because i want to add another docker container to the installation to use my kindle as a HA Dashboard.
When i try to deploy the container i get an Error that it failed to create a folder “Error read-only filesytem”. I tried manually creating the directory and change its rights to 777 but nothing helped.

Is there a solution to this problem?

Thanks in advance!

Use a Docker Volume.

I used this compose.yaml:

version: "2.4"

services:
  app:
    image: sibbl/hass-lovelace-kindle-screensaver:latest
    environment:
      - HA_BASE_URL=****:8123
      - HA_SCREENSHOT_URL=/lovelace-eink/home
      - HA_ACCESS_TOKEN=****
      - CRON_JOB=* * * * *
      - RENDERING_TIMEOUT=30000
      - RENDERING_DELAY=0
      - RENDERING_SCREEN_HEIGHT=800
      - RENDERING_SCREEN_WIDTH=600
      - GRAYSCALE_DEPTH=8
      - OUTPUT_PATH=/output/cover.png
      - LANGUAGE=de
      - ROTATION=0
      - SCALING=1
    ports:
      - 5000:5000
    volumes:
      - ./output/:/output

What did i do wrong?

You picked a local directory (./output) which is not writable. That’s my interpretation of “Error read-only filesytem”.

Are you familiar with the basics of Linux containers?

I am just a beginner. I had it running before where I Setup up raspian light by my self an the installation script for HomeAssistant.

But now I have no idea what to do

i already tried creating a folder via ssh in the base directory i see a folder “data”. In this folder i created another folder called “kindle-docker” and change the rights to 777. When i then change the Volume location to “/data/kindle-docker/output” i get the same error

i am looking for the same info. Please keep sharing this type of post ahead.

official website