Custom Google Keep Notes sensor and Lovelace card

To tell you the truth, I don’t know if there is a difference. When I needed Google keep notes sensor, I couldn’t find any solution so I created this.
Looks like this was uploaded almost at the same time.

cool stuff, i was already using this custom for a verry long time
it creates a service to add items
so that service i call with IFTTT, to add items trough google assistant :slight_smile:

would be nice to have this native in HA, but i think we still need IFTTT to pass arguments

Looks like I fixed the problem with bouncing. The problem was the naming of the sensors. Please note that when you update from github now, you need to manually specify name for each sensor.
Hope everything else works now. :slight_smile:

1 Like

I’ll check it out when I get home from work in an hour or so

I just have found your integration, it is funny that we have created our versions simultaneously :slight_smile:

is it possible to create a service wth gpeepapi, so we can something to the keepnotes from within HA?
and also use with google assistant? :slight_smile:

hi,
i am getting the following error:
create-card-element.ts:76 keep-notes-card Error: Please define entity
when define klejejs/ha_keep_notes_sensor

result = method(*args, **kwargs)
from the log:
File “/home/homeassistant/.homeassistant/custom_components/keep_notes_sensor/sensor.py”, line 79, in update
glist_items = gnote.items
AttributeError: ‘Note’ object has no attribute ‘items’

How can anyone know without seeing your code?

Please provide the yaml code you used for both sensor and card.

configuration file:

  • platform: keep_notes_sensor
    name: keep_sensor
    username: ‘[email protected]
    password: ‘PASS’
    list_id: ‘ID’

UI-lovelace file:
- entities:
- entity: sensor.keep_notes_sensor
type: “custom:keep-notes-card”

resources:

  • url: /local/card-tools.js?track=true
    type: js
  • url: /local/keep-notes-card.js
    type: js

Hi, Thank you for this integration.

Would it be possible to have a filter on the Lovelace card to show only unchecked items?

Thanks

As entity in lovelace config you should use sensor.keep_sensor as the name you defined is keep sensor, not keep_notes_sensor.

Good idea. I will try to add it in the next few days :slight_smile:

I have added the functionality you wanted. Update the lovelace card from the Github and use showChecked: and/or showUnchecked: for filtering the results.

hi,
same problem:

  • entities:
    - entity: sensor.keep_sensor
    title: “DDD”
    theme: darkcyan
    type: “custom:keep-notes-card”

That is awesome and so quick.

Thank you, works perfectly!

Do you have any notes in the note you want to see?

no only the subject.

That looks like the problem you are encountering. I will try to fix it ASAP but basically you are having an error because you don’t have anything written in the note

I have fixed the problem and pushed new file to the GitHub. Please update it. Everything should be working now.