Customize: Hidden and Friendly name not working

I had to re-initialize my z-wave stick the other day which meant I needed to make many changes to the configuration.yaml file. Most changes were pretty straightforward but I can not get customize to work. Customize, in the original file, had devices “hidden” as well as “friendly Name” assigned. I replace the entity id with the new ID but no device is hidden, no device get the “Friendly Name” assignment. This is a bit of what I got

  customize: 
    sensor.backdoor_alarm_level:
      hidden: true
    sensor.backdoor_alarm_type:
      hidden: true      
    sensor.frontdoor_alarm_level:
      hidden: true      
    sensor.frontdoor_alarm_type:
      hidden: true      
    sensor.garagedoor_alarm_level:
      hidden: true      
    sensor.garagedoor_alarm_type:
      hidden: true      
    sensor.officedoor_alarm_level:
      hidden: true      
    sensor.oficedoor_alarm_type:
      hidden: true      
    sensor.sparesensor_alarm_level:
      hidden: true      
    sensor.sparesensor_alarm_type:
      hidden: true      
    sensor.garagemotion_alarm_level:
      hidden: true      
    sensor.garagemotion_alarm_type:
      hidden: true      
    sensor.garagemotion_burglar:
      hidden: true      
    sensor.garagemotion_luminance:
      hidden: true      
    sensor.garagemotion_sourcenodeid:
      hidden: true      
    sensor.garagemotion_ultraviolet:
      hidden: true      
    sensor.aeotec_unknown_type0102_id005f_unknown:
      hidden: true      

    light.ge_backdoor_led:
      friendly_name: Ceiling 1  
    light.ge_frontdoor_led: 
      friendly_name: Ceiling 2  

I have tried several example I found online even moving the above into a separate file and using the !include… No luck.

I even tried several examples I found in the (most recent, I think) blog documentation and replaced the example entity id with my own. No luck.

I tried moving all the entities I wanted to hide into a group using the view: no
example:

  hideThese:
    name: HideEm
    view: no
    entities:
      - sensor.backdoor_alarm_level
      - sensor.backdoor_alarm_type

Each entity shows up in the Group but are not hidden

Nothing seems to work. Totally frustrated and really could use some help.

Thanks in advance
.

‘view’ defines it as separate page on your HA instance. if you don’t want it to be seen just don’t put it in a group that gets added to your views.yaml.

in customize to use friendly name:

dmain.your_zwave_assigned_name:
  friendly_name: Your Friendly Name
  icon: mdi:youriconhere(if used)

I am using “exactly” the same as your example above. Maybe spaces are out of whack???
i.e.

  customize:   
    sensor.backdoor_alarm_level:
      hidden: true

probably. but you don’t even need

  hideThese:
    name: HideEm
    view: no
    entities:
      - sensor.backdoor_alarm_level
      - sensor.backdoor_alarm_type

because if you add group.hideem to anything in views.yaml it will show

No I dont really want to use the group to hide these devices. I used it as a possible workaround to get rid of all these icon at the top of my web ui. I just want to get back to where I was before I initialized my z-wave stick. Just dont understand when I am using the same spaces and format for customize as I doid in the old version. Only thing that changes is the entityID

can you show your groups,yaml? We all do things differently so maybe it’s something you’re doing somewhere else

I’ll do one better. Here is the latest modified/newly created config file. None of the devices actually get hidden

http:
  api_password: xxxxxxxxx
  
homeassistant:
  # Name of the location where Home Assistant is running
  name: Home
  
config:
  
  unit_system: metric
  latitude: 44.893013
  longitude: -75.1871

  
  # Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones
  time_zone: America/Toronto


    
  customize:   
    sensor.backdoor_alarm_level:
      hidden: true
    sensor.backdoor_alarm_type:
      hidden: true      
    sensor.frontdoor_alarm_level:
      hidden: true      
    sensor.frontdoor_alarm_type:
      hidden: true      
    sensor.garagedoor_alarm_level:
      hidden: true      
    sensor.garagedoor_alarm_type:
      hidden: true      
    sensor.officedoor_alarm_level:
      hidden: true      
    sensor.oficedoor_alarm_type:
      hidden: true      
    sensor.sparesensor_alarm_level:
      hidden: true      
    sensor.sparesensor_alarm_type:
      hidden: true      
    sensor.garagemotion_alarm_level:
      hidden: true      
    sensor.garagemotion_alarm_type:
      hidden: true      
    sensor.garagemotion_burglar:
      hidden: true      
    sensor.garagemotion_luminance:
      hidden: true      
    sensor.garagemotion_sourcenodeid:
      hidden: true      
    sensor.garagemotion_ultraviolet:
      hidden: true      
    sensor.aeotec_unknown_type0102_id005f_unknown:
      hidden: true      


# Checks for available updates
updater:

# Enables the frontend
frontend:

# Track the sun
sun:

# View all events in a logbook
logbook:

# Allows you to issue voice commands from the frontend
conversation:

# Show links to resources in log and frontend
# introduction:

# Enables support for tracking state changes over time.
history:



# Discover some devices automatically
discovery:

wemo:
  static:
  - 192.168.1.161
  - 192.168.1.162
  - 192.168.1.163
  - 192.168.1.164
  - 192.168.1.165
  - 192.168.1.166
  - 192.168.1.167
  - 192.168.1.168
  - 192.168.1.169
  - 192.168.1.170
  - 192.168.1.171
  - 192.168.1.172
  - 192.168.1.173
  - 192.168.1.174
  - 192.168.1.175

light:
  platform: hue
  host: 192.168.1.239
  allow_unreachable: true
  

zwave:
  usb_path: /dev/ttyUSB0
  config_path: /usr/local/lib/python3.4/dist-packages/libopenzwave-0.3.0b8-py3.4-linux-armv7l.egg/config
  polling_interval: 10000
    
  
group:
  Backyard:
    - light.backdoor_led
    - switch.backyard_floods
    - switch.deck_flood_lights
    - switch.garage_side_door
  FamilyRoom:
    - light.family_room_led
    - light.fr_ottlite_led
    - light.fr_big_lamp_led
    - sensor.ct100_temp1
    - sensor.ct100_rh1
  Foyer:
    - light.foyer_led_1
    - light.foyer_led_2
    - sensor.foyer_motion_relative_humidity
    - sensor.foyer_motion_temperature
    - sensor.foyer_motion_luminance
  Frontyard:
    - light.frontdoor_led
    - light.garage_out_1
    - light.garage_out_2
  FurnaceRoom:
    - switch.furnace_room_lights
    - sensor.freezer_st814_relative_humidity
    - sensor.freezer_st814_temperature
  Garage:
    - light.garage_in_1
    - light.garage_in_2
  GarageMisc:
    - switch.garage_opener_switch
    - switch.garage_outlet_switch
    - switch.gopeneroutlet_switch
    - switch.spa_wifi_connect_switch
    - sensor.garagemotion_relative_humidity
    - sensor.garagemotion_temperature
  MasterBR:
    - switch.insight_sunroom
    - switch.bedroom_lamps
  Misc:
    - switch.basement_foyer
  OfficeMain:
    - light.office_led_b
    - light.office_led_w
    - switch.officeoutlet_switch
    - switch.office_speakers
    - sensor.officeenergyswitch_energy
    - sensor.officeenergyswitch_power1
    - sensor.officeenergyswitch_prevread1
  OfficeCeiling:
    - light.ge_backdoor_led
    - light.ge_frontdoor_led  
    - light.ge_garage_in
  OfficeMisc:
    - switch.insight_charger
    - switch.office_pc_energy_switch
  SumpPumpRM:
    - light.sump_pump_led_1
    - light.sump_pump_led_2
    - light.sump_pump_led_3

    

# ==========================Set Automation Here===================================

# ======================================================================

# ======================================================================
notify:
  name: EventGhost
  platform: rest
  resource: 'http://192.168.1.231:88/'
  method: GET
  message_param_name: 'RaspPi.'

# ======================================================================
notify 2:
  name: EG
  platform: command_line
  command: "curl http://192.168.1.231:88/?RaspPi.De-Humidifier.On"

It’s not working because it’s in the wrong place in the file I think…

homeassistant:
  name: 'Home'
  latitude: xxxxxxxx
  longitude:xxxxxxx
  elevation: 70 
  time_zone: Europe/London
  unit_system: metric
  customize:

Also I don’t think you can have http: before homeassistant:

Also you can’t have config: there either :frowning:

So configuration.yaml should look like this …

homeassistant:
  name: 'Home'
  latitude: xxxxxxxx
  longitude:xxxxxxx
  elevation: 70 
  time_zone: Europe/London
  unit_system: metric
  customize: !include customized.yaml

config:
http:
  api_password: xxxxxxxxx

Inside customized.yaml

  sensor.alarm_hour:
    hidden: true
  sensor.alarm_minutes:
    hidden: true
  sensor.alarm_hour_fin:
    hidden: true

Then it should work :smiley:

If you don’t want to use a seperate file for customizations, just put them under customize: but indented by a further 2 spaces…

  customize:
    sensor.alarm_hour:
      hidden: true
    sensor.alarm_minutes:
      hidden: true
    sensor.alarm_hour_fin:
      hidden: true

it’s in the right spot. here’s mine

homeassistant:
  name: !secret house_name
  latitude: !secret home_lat
  longitude: !secret home_long
  elevation: !secret elevation
  unit_system: imperial
  time_zone: America/New_York
  customize: !include includes/customize.yaml

This is what his should look like

homeassistant:
  name: Home
  unit_system: metric
  latitude: longitude
  longitude: latitude
  time_zone: America/Toronto
  customize:   
    sensor.backdoor_alarm_level:
      hidden: true
    sensor.backdoor_alarm_type:

on so on

I have a feeling config: ... is causing a problem… I could be wrong though

1 Like

No you are not wrong :slight_smile: Disabling config and everything worked. I moved it below customize and re-enabled it. All is good and everything working well.

Thanks everyone, particularly forsquirel, for all your help :wink: