Dafang camera not communicating with HA

I flashed my Neos Smartcam with success. I can confirm I have access to the Web UI, SSH, and I can see the camera with its stream in Home Assistant, using the Generic IP Camera integration.

I want to be able to get all the sensors and actions in HA, as illustrated in the HA guide on the Dafang repo.

I have other Zigbee devices (switches) detected through the MQTT moquitto broker and Zigbee2MQTT. This is 100% working.

My switches were detected after I permitted devices in Zigbee2MQTT. But I can’t find a way to trigger discovery / pairing for the camera.
I can’t find the camera and all its sensors. I would like to use it to create automation on motion detection, etc.

  • I modified the dafang config to connect to my local HA server, homeassistant.local. I also tried core-mosquitto, as it’s used by Zigbee2MQTT
  • I restarted the dafang camera, got it off and on again, restarted services
  • I restarted HA, checked the config, user access

There’s no trace of connection, successful or not, in the logs.

Any idea?

Under network services configuration, have you have you set the auto-discovery topic to “homeassistant”?

Yes the topic is set to homeassistant

I solved that issue by doing the below (not sure which one was missing tbh):

  • put the user credentials directly in the yaml of the mosquitto broker
  • added listener: 1883
  • added allow_anonymous: true
  • changed the host for the IP address of the VM
    Hope that will help someone!

Nice Job!!!