Decimal point wrong (esphome)

hello,
from my esphome i get this value:
image

it should be 10.000,01
comma -> point
point -> comma

in my config i use

unit_system: metric

how can i change this?
at least in the dashboard this should be displayed according to the metric standard.

That is not the metric standard. It is a european language setting. We use metric here in NZ yet still use comma for thousands and dot for decimals.

Decimal notation is setup from your language, not the units on the system. If your language outputs 10,000.09 m^3 then there’s nothing you can do to change the format.

ok, thx. that was the problem.
my target was: homeassistent with english ui and lovelace with german ui. seems
that isnt possible. switch all to german. now it looks good.

perhaps a wish for the future: different language settings for HA and Dashboard.