deCONZ Conbee setup help


#1

I just got my Conbee Zigbee USB stick today but i am having trouble setting it up.

I have HA 0.73 in a docker on a Ubuntu 16.04 NUC.

First I installed the docker from marthoc/docker-deconz and set my docker_compose.yaml as-

  deconz:
    image: marthoc/deconz
    container_name: deconz
    network_mode: host
    restart: always
    ports:
      - "8103:443"
      - "8100:80"
    volumes:
      - /opt/deconz:/root/.local/share/dresden-elektronik/deCONZ
    devices:
      - /dev/ttyUSB1
    environment:
      - DECONZ_WEB_PORT=8100
      - DECONZ_WS_PORT=8103
      - DEBUG_INFO=1
      - DEBUG_APS=0
      - DEBUG_ZCL=0
      - DEBUG_ZDP=0
      - DEBUG_OTAU=0

I had to set the Devices to /dev/ttyUSB1 because i am using /dev/ttyUSB0 for my RFXCOM.
Ran the docker_compose and then add the deCONZ to the ‘Set up a new integration’ in HA
and then set the deCONZ web page http://192.168.85.5:8100/pwa/settings-gateway.html#advanced to
Allow authentification for 3rd party apps for 60 seconds. and HA had set up the config.

Rebooted HA and got

2018-07-07 18:10:57 INFO (MainThread) [homeassistant.components.binary_sensor] Setting up binary_sensor.deconz
2018-07-07 18:10:57 INFO (MainThread) [homeassistant.components.scene] Setting up scene.deconz
2018-07-07 18:10:57 INFO (MainThread) [homeassistant.components.light] Setting up light.deconz

So i tried to add some IKEA lights (doing a reset on the Light) using the Phoscon App web page but
nothing appears. So i stopped the docker and tried the deCONZ software.

I managed to see all my lights using the deCONZ software which means the Conbee USB is working.
Put back to the Docker and restarted but still cant see any lights from within the docker.

So any help would be most grateful.


#2

Remember that when you restart your machine there is no guarantee that any usbdevice will keep its enumeration eg usb0 or usb1

A user has identified that you can remap a USB point into the docker container

See this issue for more details https://github.com/marthoc/docker-deconz/issues/29


#3

Thanks @Robban
I will have a go at this but at moment I have the Conbee connected to my Windows Pc and linked to HA (NUC) and all is working fine.


#4

Hi, my Conbee just arrived. Works fine on my windows 10 pc with the Conbee on a USB port.

My HASSIO installation is on NUC Ubuntu, but
I have problems with my deconz Ubuntu program does not start.

Which are my options can I put the Conbee on a spare pi3 and tell HASSIO to look for the Conbee there?


#5

I keep the deConz software running on my windows pc that is running all the time for my Security Camera software. And use the Phoscon App to allow Auth for 60 seconds.

Then goto HA and in the Configuration - Integration - Set up a new integration Use deconz Zigbee gateway to setup the rest.


#6

Yes that worked from windows 10.

But I don’t have /want a windows 10 always on pc server.

Preferably I want to use the NUC Ubuntu that has HASSIO too and plug in the Conbee , or if that doesn’t work a raspberry pi3 and plug in the Conbee in the pi3


#7

Putting the Conbee in the NUC I can log in it. But going to HASSIO and Link with deconz gives error
Couldn’t get an api key


#9

When I move the Conbee stiock from one hardware to another it looses all configuration?

I assume yes, so basically the way to go is to use the Conbee stick on a Laptop, move it around adding things (I have a bunch of Xiaomi sensors around the house), when finished to a backup, then insert the Conbee stick on my server that stays on 24h, restore configuration and keep it there, correct?

Sorry trying to figure out how this all works is way more difficult (to me) as imagined


#10

Database and everything should be available on the system so you could copy them between machines if you want to, I have never tried to personally though


#11

I don’t know why but when I attach the Conbee to the Ubuntu NUC nothing gets discovered, plus I can’t install deconz software hence difficult to debug.

When the Conbee is on my laptop it is better, although adding devices is a hit and miss (after 3-5 attempts works).

Of course I can’t keep the Conbee on the laptop 24/365 so that’s a problem.

Hope to add enough devices, so to have a strong mesh, and then move the Conbee to the NUC and add all devices there more easily.

Nevertheless it’s a pain, I have 100 devices to add…


#12

Other issue. I have, for example a hue bulb named light.lamp.
What I did is remove it from Hue bridge, turn off from main, on again, and then add to the Conbee, I renamed it lamp.

Now in HASSIO deconz it is renamed light.lamp_2 and in HASSIO I can’t rename it in light.lamp because its taken.
How to fix this?


#13

no, its not working, at least I am not able to


#14

do you know where it is actually stored? On the Conbee itself, or on the host?


#15

On the filesystem.

In your users home directory it should be available under this path .local/share/dresden-elektronik/deCONZ


#16

strange its not there, and can’t find anywhere else. Although a light and a switch is in the phoscon app …

User should be my usual Ubuntu user, correct?


#17

The user who is running deconz


#18

I managed to get it working in Ubuntu. Seems a problem with dependencies solved by uninstalling mariadb mysql and reinstalling mysql server


#19

Now it works in the GUI in the webapp but not in phoscon app. In HASS was able to connect deconz but can’t control devices.

To me it’s a beta, maybe alpha, product, definetly complex (for me)