Deconz for Hass.io


#205

Unfortunately I’m bad at reading and tried updating and starting the addon without specifying the device name in my config. I restarted home assistant and now the frontend won’t load, but I still have access to my config files and can SSH into my pi. My config is ok, and the only errors I’m getting in my log are from pydeconz. What would be the best option for editing my addon config or for getting this fixed?


#206

Which is the correct format for specifying the device location? Mine is just

"deconz_device": "ttyUSB0"

Which is working fine but the documentation suggests:
"deconz_device": "/dev/ttyUSB0"

I tried with the by-id path:

"deconz_device": "/dev/serial/by-id/usb-FTDI_FT230X_Basic_UART_DO00KCPH-if00-port0"

But this didn’t work. Was hard to get it back up and running after this failure too. Had to restore old version of deconz add on. Didn’t work. So I upgraded. Added the path, and eventually it worked. Great it’s working again, but it would be good if it worked on the by-id path as this is apparently permanent, rather than the tty paths that change.

Thanks for all your contribution to HA.


#207

I’ve two Xiaomi Switches that stopped working after the last deconz add-on update.

One is an aqara smart switch.

download

It’s showing only the battery.

41

The second is a Wireless Double Switch:

40
Screen Shot 2018-10-15 at 09.47.40.jpeg922x958 31.8 KB

And its showing like that:
46

Any help?


#208

Well none of them should really show as a switch. They should all just be events in hass.

To get support you need to enable debug and post logs.


#209

I am getting in the logs that there is a new firmware version, but instead of updating through Hassio / ssh I figured I might as well put the conbee i a PC running windows and update the firmware. But strangely enough it in the Phoscon webapp says the firmware is up to date. Is there any difference in the updates available on the different platforms? I have firmware 261F0500.

The deconz log states:
21:32:54:179 dev /dev/ttyAMA0
21:32:54:180 GW firmware version: 0x261f0500
21:32:54:180 GW firmware version shall be updated to: 0x262d0500

I am also a little confused about why the log states “dev /dev/ttyAMA0” when I have told the device location in the config as “deconz_device”: “/dev/ttyUSB0”,


#210

I’ve been trying to add the Deconz Gateway to Hassio in a futile way for a long time. I installed the Raspbee and the Deconz Addon on my Pi 3b+ . The Raspbee is recognized and I can also add lamps. But Hassio does not automatically find the Deconz Bridge (discovery in the config is enabled). When I add “deconz: host: IP” in the config, it detects the deconz bridge but I can’t add it because it can’t get an API key even though I unlock the gateway. With my Android app I could find and add the Deconz Bridge.

Does anyone know why?


#211

Enable debug and share logs. If you did what you say you did it should work.

If you specify deconz manually in config you need to specify port unless it runs on port 80. If you have a key you can specify that as well and it should work after restart of hass.


#212

Ah thank you for the tip! I have defined the port incorrectly in the configuration. ( host: IP:Port.
Added this to my config

deconz:
host: IP
port: 8080

Now everything is working fine :slight_smile:


#213

Does your conbee show as a raspbee in Phoscon on hassio? - mine does which might also be the source of it saying there is an update. It otherwise works fine though.


#214

Mine does show up as a conbee stick. And in the phoscon Web ui via Hassio is states there is a new update. If I put the stick in a windows pc it states no updates


#215

I have spent many hours the last week trying to get the deconz addon to work on my system (rpi + hassio + conbee). The addon installed like it should, but I kept getting the error message “no deconz bridges discovered” when trying to configure in “integrations”. I have tried a lot of the advice given in several threads here in the community. What finally seems to have been the working trick was to change “deconz_device”: “/dev/ttyUSB0” to just
“deconz_device”: “ttyUSB0"
So thanks for pointing me in the right direction!


#216

HI,

making progress , I think…, but not enough just yet. please see https://github.com/marthoc/hassio-addons/issues/26#issuecomment-437129573 for the logs?

Seems the Conbee stick is working? Or is this log indicating something of a problem.

I can’t get Hassio to recognize the Conbee , or Phoscon for that matter. So heavily stuck for now ;-(

after manually configuring in configuration.yaml, i get to this:

homeassistent debug log:

2018-11-09 08:48:07 DEBUG (MainThread) [pydeconz.utils] Sending {'auth': None, 'data': b'{"devicetype": "pydeconz"}'} to http://192.168.1.165:8080/api
2018-11-09 08:48:08 ERROR (MainThread) [pydeconz.utils] HTTP status 403, response [{"error":{"address":"/","description":"link button not pressed","type":101}}].

apparently need to go to settings in deConz, but I can’t find that…nor does the Phoscon scan find a gateway


#217

I tried install DeConz with marthocs addon, but got this error

ERROR (SyncWorker_0) [hassio.docker.addon] Can’t build 62fc4c59/aarch64-addon-deconz:2.05.22: The command ‘/bin/sh -c apt-get update && apt-get -y --no-install-recommends install xauth wget libqt5core5a libqt5network5 libqt5widgets5 libqt5gui5 libqt5serialport5 libqt5websockets5 libqt5sql5 libcap2-bin sqlite3 xpra’ returned a non-zero code: 127

I have tried to google the error code, but got nothing useful. Please help


#218

That is a really old version 2.05.22


#219

Ok. Seems like I wasn´t using marthocs add-on, but neffs. Hope this will help. At least the installation was successful this time. Pretty frustrating but it will be worth it in the end.


#220

I’m picking up the update firmware that’s mentioned eariler.

I’m getting the same in the logs:

21:05:23:245 dev /dev/ttyAMA0
21:05:23:245 GW firmware version: 0x260b0500
21:05:23:245 GW firmware version shall be updated to: 0x262f0500

Here it’s stated ttyAMA0 but in my config it’s ttyUSB0. Everything is working just fine, but I was thinking that it wouldn’t hurt to do the upgrade anyway. Since I’m not getting the file name for the upgrade, I’m not able to do it. I’m using a Conbee stick.

Ideas?


#221

With hassio you have to update your stick on a different computer


#222

Hey all, I’m trying to get a Raspbee running on a Pi 3B/Hass.io installation and I’m unsuccessful so far so I hope someone can help.

I’ve added the addon, also added the lines to config.txt and that’s all up and running. Can open the Phoscon UI but it can’t find the gateway. On the top right Phoscon shows the IP address 192.168.2.1 while the Pi is on 192.168.2.23, could this indicate something wrong?

The Hass.io System tab shows there’s a device on /dev/ttyAMA0.
The System logs show these deconz related entries:

18-12-06 20:45:09 INFO (SyncWorker_9) [hassio.docker.interface] Stop marthoc/hassio-addon-deconz-armhf Docker application
18-12-06 20:45:09 INFO (SyncWorker_9) [hassio.docker.interface] Clean marthoc/hassio-addon-deconz-armhf Docker application
18-12-06 20:45:12 INFO (SyncWorker_7) [hassio.docker.addon] Start Docker add-on marthoc/hassio-addon-deconz-armhf with version 2.05.49

The addon log shows:

[Hass.io] Starting deCONZ Hass.io Addon...
[Hass.io] Current deCONZ version: 2.05.49
[Hass.io] Web UI port: 8081
[Hass.io] Websockets port: 8443
[Hass.io] deCONZ device: /dev/ttyAMA0
libpng warning: iCCP: known incorrect sRGB profile
This plugin does not support propagateSizeHints()
This plugin does not support propagateSizeHints()

I’ve tried most of the other suggestions here in the thread but I’m at a loss, thanks in advance for any help!


#223

Did you properly add a new line at the end of the file?


#224

Started to doubt and double checked, but yes I did :slight_smile: