Deconz for Hass.io


#287

It seems like my setup is running at port 80, but the core.config_entries states port 8080?:

{
“connection_class”: “unknown”,
“data”: {
“allow_clip_sensor”: true,
“allow_deconz_groups”: true,
“api_key”: “DFSDF”,
“bridgeid”: “XXX”,
“host”: “192.168.86.20”,
“port”: 8080
},
“domain”: “deconz”,
“entry_id”: “b5b68f5c112440208b5dc6492aa7d3b9”,
“source”: “discovery”,
“title”: “deCONZ-00212EFFFF027908”,
“version”: 1
},


#288

You updated hassio addon? Its a bug in the addon


#289

Yes I updated the add on, but that resulted in a non functional add on. As I understood it, it should be possible to bring it back to life be changing the port to 8080, but mine already states that.


#290

I think it reverts to port 80. There’s an issue on marthocs github


#291

I just got deconz running up perfectly :sunny:

thank you for the support guys! I must say it was quite a challenge for me to get the setup correct…
Especially the firmware update of the rasbee via ssh took me awhile…

But now the one philips motion detector i have works like a charm… the update is instant despite of having a metal case for my raspberry pi. Going to buy additional sensors now :smile:

Thx for the awesome plugin marthoc.


#292

Glad to hear you getting it up and running. Marthoc definitely has done a great job on the component :+1:t2:


#293

I can’t seem to find if there is an update under way or if I need to remove the integration and redo it.


#294

[quote=“Robban, post:286, topic:41165”]
ou can also change the port of the component, then you won’t need to reauthenticate. Go into .storage/.core.config_entries and change deconz port
[/quote]the solution has been posted :slight_smile:


#295

Hi, that was what I looked into, but according to my entries file it already states 8080, isn’t that correct?


#296

Yes but the error with addons is that they revert to port 80


#297

Okay so I should change it to 80 instead?


#298

Yes. You should at least try it


#299

It worked, thanks :grinning:


#300

I just pushed 2.05.57 of the docker image and Hass.io addon. Fingers crossed that this fixes issues for Hass.io users!


#301

Phoscon App is still running on port 80.


#302

not for me, back to port 8080


#303

It should be fixed. Can you check your addon settings.


#304

It is working now, sorry. Phoscon App is running on port 8080. But HA couldn’t connect to it first, because it was still trying to connect to port 80 (web_port was set to default 8080).

Error getting deCONZ data from http://192.168.178.101:80/api/8B96F0804E.

I did several restarts, hard reboots, restarted the addon, removed and added the deCONZ integration. Maybe I wasn’t patient enough.

Thanks for your work @marthocoo


#305

Has anyone run in to HassIO randomly losing authentication to the deCONZ docker image?

I rebooted my PI last night, went to bed, woke up to find that HA and deCONZ were no longer speaking to each other. deCONZ is running. I can access the Phoscon web panel. But the authentication link between the two seems to be dead.

Is it possible to root cause this, restore the link, etc.?

(If there’s an actual deCONZ section for Hass.IO and I shouldn’t be posting in this thread, please do let me know.)


#306

You’re other alternative would’ve been to alter the port in.storage/core.config_entry