Device_Tracker Config Error

Hey all,

I set up the device_tracker component in config file and it worked for a few months until recently when It started to give this error message.

Logger: homeassistant.setup
Source: components/device_tracker/legacy.py:303
First occurred: May 23, 2022, 4:28:32 PM (1 occurrences)
Last logged: May 23, 2022, 4:28:32 PM

Error during setup of component device_tracker
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/setup.py", line 235, in _async_setup_component
    result = await task
  File "/usr/src/homeassistant/homeassistant/components/device_tracker/__init__.py", line 50, in async_setup
    await async_setup_legacy_integration(hass, config)
  File "/usr/src/homeassistant/homeassistant/components/device_tracker/legacy.py", line 158, in async_setup_integration
    legacy_platforms = await async_extract_config(hass, config)
  File "/usr/src/homeassistant/homeassistant/components/device_tracker/legacy.py", line 303, in async_extract_config
    raise ValueError(
ValueError: Unable to determine type for netgear: None

Below is copied from my config file

device_tracker:
  - platform: netgear
    host: 192.168.1.1
    username: !secret netgear_username
    password: !secret netgear_password
    interval_seconds: 10
    consider_home: 180
    new_device_defaults:
      track_new_devices: true

Any help appreciated.

Try deleting the YAML config, restarting HA, then setting it up in the UI.

Tried this but when I try setting it up with UI, the dialog box says “An Unexpected Error Occurred.”

Have you restarted your router lately? If not try that?

Found in a related reddit thread.