Device tracker issue - Just 1 phone in the household is not tracked correctly

I’ve got a problem with tracking just 1 specific mobile phone. It seems to have been an issue since implementing HA and now I’m out of ideas. Only very occaisionally does the device appear to be ‘Home’. Im currently running v0.103.0 in a docker container on a Raspberry PI 3b+ No problems encounered with any other configurations; HACS, WLED, Konnected. It’s been the same on multiple versions.

I’m using BTSmartHub tracker:

  - platform: bt_smarthub
    interval_seconds: 120
      track_new_devices: true

The phone appears in known devices:

  hide_if_away: false
  mac: 6C:C7:EC:46:6D:5C
  name: 6c c7 ec 46 6d 5c
  track: true

The hub knows the device is online (homehub-cli):
157 6C:C7:EC:46:6D:5C WiFi Yes

But HA believes its away
device_tracker.6c_c7_ec_46_6d_5c not_home source_type: null friendly_name: 6c c7 ec 46 6d 5c

I have noticed that source_type is null whereas other tracked phones are have a source_type of router and various other attributes.

In the past i’ve tried renaming the device, removing it from known_devices.yml and deleteing home-assistant_v2.db.

I’m currently only logging a few devices as the database becomes quite large due the amount of devices but even when logging everything its the same result.

      - sensor
      - switch