Device_tracker nmap - "known_devices" settings are ignored

Hi!

I just started using Home Assistant a few days ago and I love it! I’m working through my configuration and I’m trying to use the device_tracker to manage devices on my network.

I am successfully finding all my devices with nmap (something like 40+) but I can’t for the life of me figure out how to change the name and Icon on the device. I’ve manually mapped out my network and I can tie icons and names to most of my MAC addresses in a spreadsheet, but when I stop the server and edit known_devices.yaml I find the settings are ignored! The device name is still the discovered host name and the icon and the picture seem unused.

Is there some way to use then “name” and “picture” or “icon” values? Am I doing something wrong or are those values just ignored?

Thanks!

Jake

To customize devices icons and names, use the customize section:

example:

  customize:
    device_tracker.wemo:
      friendly_name: Wemo
      icon: mdi:something

Thanks, that seems to work but the documentation specifies you can configure the names with “known_devices.yaml” which seems to be ignored. Is there some way to make that work or am I not understanding the documentation correctly?

It depends on the known_device. Some of them when auto detected will overwrite your stuff, some don’t. I don’t have a wemo so I don’t know. Typically, if the device has a mac address, all you need to do is change the icon and name, when HA starts, it won’t touch those settings if the mac address matches when it’s chugging through everything it finds.