Devices not showing on Amazon Alexa App, no voice control

Evening All,
I had an issue where new devices were not being exposed to my Amazon Echos, so today I cleared al of my previous devices in the Alexa app, and rescanned for devices.
Now no devices are now being exposed to Amazon.

I have tried to disable the home assistant skill, followed by enabling it, reconnecting my account and then running a discover.
I have tried to sign out of my Nabucasa account, and sign back in, within homeassistant followed by a discover.
I have tried the sync-entires button, followed by a discover devices in the app.

My nabucasa account is live and active
My password hasn’t changed recently.

Any ideas why my devices are suddenly not showing?

Are you exposing a media_player? Currently there appears to be an issue with specific media_players causing discovery to silently fail.

I was, but took that out of my config. I run discover again a few minutes ago, and it seems to have pulled everything now. - not sure why, been trying for a couple of hours!