Did I just brick my NodeMCU?

So I’m very new to using ESP8266 boards, and just got a NodeMCU to try to connect relays and a HC-SR04. I managed to get the relays to work using ESPHome, then I moved on to trying out the HC-SR04. I uploaded the codes and connected the pins:
Trigger to D1
Echo to D2
VCC to VIN (the seller said my HC-SR04 runs at 5V)

I powered the board using the micro USB connected to an Anker powerbank. The entity showed up so I created a card to check the readings. It came out as “Unavailable”, so I powered down the board and powered it on again just in case it needed a restart. It still showed “Unavailable”. I restarted it several times just to be safe, but it still didn’t work. So I unplugged it.

I searched around in the forums on how to get the sensor working, but got no helpful results so far. So I tried powering it on again, but now it won’t show up as “online” on the ESPHome tool in HA. I unplugged all the pins and checked my wireless router settings and found out that it’s not connected to the network. Then I checked the VIN pin against the GND pin using a multimeter and found out that it’s only outputting around 1.75V and the 3V3 to the GND only outputs 0.9V.

In a desperate attempt, I tried to delete the board from the ESPHome and intended to reconfigure everything using a USB connection, but it won’t show up either. it only shows OTA (Over The Air) on the top right menu bar.

While connecting the pins to the HC-SR04, I did find out that some of the dupont connectors were bad, so I had to switch them out and tested the continuity using my multimeter. The board was powered on when I did that, so it’s possible I shorted the pins several times.

So is it possible that I just bricked my NodeMCU?

Sounds like you have burnt out the 3.3v regulator. Are you any good at SMD soldering?

1 Like

Did you try hooking it up to a usb charger?
Perhaps it’s the power bank?

Hi Tom! First of all, thanks for moving this thread to the correct category.

Are you talking about the AMS 1117? Is there a way to make sure that it’s the 3.3v regulator that’s broken? What do you think caused it to burn out?

I’m more used to soldering normal sized components like audio components, but the component doesn’t look that small. Is it different from normal soldering?

I tried plugging it to an iPad charger, voltage readings from VIN and 3V3 is still the same

Shorting the output to ground.

I’m my two years of fiddling with nodemcu’s I’ve managed to fry more than I care to admit. Usually because I touched two wires together that should never have been touched. Each time I do it, I try to reflect on how stupid it was to do whatever it was that I did to fry it, and then I chunk it in the trash and grab another from the drawer. I just buy them by the dozen from China now. Takes the pain of failure away when they cost less than $2 or whatever they are down to now.

I guess I’ll try replacing the regulator then. Thanks!

So it’s not just a rookie mistake then? :grin:
Oh well, I guess I’ll try replacing the regulator first thought before chucking it into the trash. Have you ever tried to resuscitate or successfully resuscitated a broken board before?

I made the same mistake (wemos D1 mini). I am now powering it up trough the 5v and ground pin.