Different views on mobile devices

Hi,

I fear it’s an topic, that is often discussed here, but I couldn’t find a solution for myself. I started with Home Assistant and I’m very impressed on it. It’s much more comfortable than FHEM, that I used for years before.

I installed Hacs, Custom Header and a custom Theme (iOS Dark Mode Theme). On my PC it’s everything all right.

But when I open the Frontend on my iPhone or on Amazon Fire HD (it will be the main device on the wall…) it looks very ugly. No transparent Cards, no background image.
On the iPhone native App, it seems like Custom Header is not loaded,and on iPhone Safari and Fire HD Fully Kiosk, the background image is not loaded and the Custom Header and the cards are not transparent.

On iPhone native App:

On iPhone Safari (same on the tablet):

Could you give me a short hint, where I have to look? As now, I do not make differences between the users, I’ll do it later, so that the tablet user will get another view than the iPhone user, as the PC user… That will not be the problem, when I know, where the current issue is.

Versions:

  • HassOS 3.13 installed on a Raspberry Pi
  • Home Assistant Core 0.109.6
  • Custom Header 1.3.8
  • iOS Dark Mode Theme: ece552c

The view on the iPhone is not so important for me, but on the Fire HD it is…

Thanks in advance,
Lars

1 Like

Go to your user profile in the app and fire tablet and for the theme setting make sure “back end selected” is selected.

1 Like

Kindle Fire use an old version of Webview, and custom cards may not work correctly. It’s a problem with cheaper tablets, and Amazon devices in particular (because OS updates are controlled by Amazon). What version of iOS is phone?

Many thanks. That was the issue. But it was on “back end selected”, and when I switched to “iOS Dark Theme” it works! I never had searched there for the solution :slight_smile:

@NK553: It’s the latest version for iPhone 11 Pro. But as said, in this case, I did not select the right theme on the right device…

Thanks for the fast answer!
Lars

Ah that’s probably because you are not using the set theme service in an automation or script (for day/night theming). If you only have the one theme what you did was correct.