Do not receive info from dutch smart meter (DSMR)

Since friday I have a DSMR. I have a RPI zero W connected to the DSMR and want to sent the values with ser2net to the home assistant server.
The RPI zero W does receive informtion (I checked it with cu -l /dev/ttyUSB0 -s 115200 -E% so it must be something with ser2net.
The command line in ser2net.conf is : 2001:raw:600:/dev/ttyUSB0:115200 NONE 1STOPBIT 8DATABITS XONXOFF LOCAL -RTSCTS

Setting in sensors.yaml are :

- platform: dsmr
  host: 10.0.0.26
  port: 2001
  dsmr_version: 5

In groups.yaml I have :

meter_readings:
  name: Meter readings
  entities:
    - sensor.power_consumption
    - sensor.power_consumption_low
    - sensor.power_consumption_normal
    - sensor.power_consumption_phase_l1
    - sensor.power_consumption_phase_l2
    - sensor.power_consumption_phase_l3
    - sensor.power_production
    - sensor.power_production_low
    - sensor.power_production_normal
    - sensor.power_production_phase_l1
    - sensor.power_production_phase_l2
    - sensor.power_production_phase_l3
    - sensor.power_tariff
    - sensor.voltage_sags_phase_l1
    - sensor.voltage_sags_phase_l2
    - sensor.voltage_sags_phase_l3
    - sensor.voltage_swells_phase_l1
    - sensor.voltage_swells_phase_l2
    - sensor.voltage_swells_phase_l3
    - sensor.long_power_failure_count
    - sensor.gas_consumption
    - sensor.hourly_gas_consumption   
'''' 
However all the state values are unknown.
What can I do more to check what is wrong. ?
Normally I connect to home assistant through duckdns


EDIT: With realterm I checked the output on my pc. Because I receive information I believe that settings in ser2net.com are correct and it must be a wrong setting in Home assistant

This is how the ouptut looks like :  
1-3:0.2.8(50)
0-0:1.0.0(190401171820S)
0-0:96.1.1(4530303437303030303438373131303138)
1-0:1.8.1(000016.446*kWh)
1-0:1.8.2(000006.458*kWh)
1-0:2.8.1(000000.006*kWh)
1-0:2.8.2(000000.000*kWh)
0-0:96.14.0(0002)
1-0:1.7.0(00.573*kW)
1-0:2.7.0(00.000*kW)
0-0:96.7.21(00003)
0-0:96.7.9(00001)
1-0:99.97.0(0)(0-0:96.7.19)
1-0:32.32.0(00002)
1-0:32.36.0(00000)
0-0:96.13.0()
1-0:32.7.0(227.0*V)
1-0:31.7.0(003*A)
1-0:21.7.0(00.573*kW)
1-0:22.7.0(00.000*kW)
!0E8F
/Ene5\XS210 ESMR 5.0

1-3:0.2.8(50)
0-0:1.0.0(190401171821S)
0-0:96.1.1(4530303437303030303438373131303138)
1-0:1.8.1(000016.446*kWh)
1-0:1.8.2(000006.458*kWh)
1-0:2.8.1(000000.006*kWh)
1-0:2.8.2(000000.000*kWh)
0-0:96.14.0(0002)
1-0:1.7.0(00.589*kW)
1-0:2.7.0(00.000*kW)
0-0:96.7.21(00003)
0-0:96.7.9(00001)
1-0:99.97.0(0)(0-0:96.7.19)
1-0:32.32.0(00002)
1-0:32.36.0(00000)
0-0:96.13.0()
1-0:32.7.0(227.0*V)
1-0:31.7.0(003*A)
1-0:21.7.0(00.589*kW)
1-0:22.7.0(00.000*kW)
!6EFC
/Ene5\XS210 ESMR 5.0

Did you ever find a solution?
I have the same problem after following these steps: https://cloudenius.com/2018/08/04/use-smart-energy-meter-with-home-assistant/

Yes I did. Unfortunately I don’t remember what the trigger was to make it work.
Did you check with realterm that the PI zero sends info ?

Rebooting the PI zero did not help ?
I will try to find the changes I made, but don’t promise it will be today, very hot in here :slight_smile:

Great so there’s still hope :slight_smile:
Reboot was the first thing I tried. I don’t know realterm so googled it a bit but I have a hard time finding out how I can use it to test if ser2net is reachable from another device.
Ideally I’d like to test from my laptop or NAS the cu command to see if the connection is up, but I have no idea how :stuck_out_tongue:

Turns out that I didn’t comment out the default lines at the bottom of the ser2net.conf file and thus was using the same port twice.
After commenting out the defaults it works great :smiley: