Docker Node Red Installation using Armbian ARM64 not working for me

I am currently running Ubuntu 18.04 64 bit on a Pine64.

I have a duplicate set up running on an Intel quad core with 2 Gb with no issues at all. I want to shrink the footprint a bit to RPi size (using a new Octocore Arm with 4Gb of RAM and an eMMC drive and testing this setup up on the Pine64

_  _             __   _  _   
|  _ \(_)_ __   ___ / /_ | || |  
| |_) | | '_ \ / _ \ '_ \| || |_
|  __/| | | | |  __/ (_) |__   _|
|_|   |_|_| |_|\___|\___/   |_|  
                                 

Welcome to ARMBIAN 5.75 stable Ubuntu 18.04.2 LTS 4.19.20-sunxi64   
System load:   0.00 0.00 0.00      Up time:       1 day        
Memory usage:  17 % of 2001MB     Zram usage:    3 % of 1000Mb     IP:            192.168.244.149
CPU temp:      37°C               
Usage of /:    27% of 29G        

Last login: Mon Mar 25 09:55:30 2019 from 192.168.244.231

I have installed aarch64 version of Home Assistant via Docker and it is working well.

For whatever reason when I install node red it just keeps restarting.

The assumption here is my incorrect nomenclature to install it.

Using:

1 - docker run -d -p 1880:1880 -v /opt/node-red/data:/data --name mynodered --user root --restart unless-stopped hassioaddons/node-red-aarch64 * keeps restarting

2 - docker run -d -p 1880:1880 -v /opt/node-red/data:/data --name mynodered --user root --restart unless-stopped nodered/node-red-docker * keeps restarting

I have Home Assistant running fine using the aarch64 version.

Server: Docker Engine - Community
Engine:
Version: 18.09.3
API version: 1.39 (minimum version 1.12)
Go version: go1.10.8
Git commit: 774a1f4
Built: Thu Feb 28 06:00:18 2019
OS/Arch: linux/arm64
Experimental: false

Am I installing Docker Node Red incorrectly?

Please help?