DuckDNS - It's not just me - it's you!

Petro, you are kinda proving my point.
I clarified the statement, I pointed out that this is not the devs fault that some users are left in no-mans land and I suggested some alternatives (thank you for listing / pointing to these alternatives in concrete terms).
I have no anger towards the devs, where did I evince any ?
I did not intend to trip anyones defences
This may help some users get back on track.
My point is that I will no longer be maintaining this thread and that users should look elsewhere.

Just turn off watch then, no need to kill the thread.

By default, when you create a thread, the forums sets the thread to watch for the person who created it. Everyone else will be lumped into tracking. It’s never the responsibility of a thread poster to monitor and maintain the thread. Ghost if you need, other people can pick up the slack.

1 Like

Hi all,

I have been using this thread to set up DuckDNS with NGINX Home Assistant SSL proxy to have access to my HA through https://mydomain.duckdns.org/ and an internal adres localip:8123.
I think I am almost there, because I have DuckDNS running and have access (when I am outside ánd when I am on my network) when entering https://mydomain.duckdns.org.
I only don;t have access when I want to approach my HA over my local network…

I noticed there was a warning in Settings → Network saying “You have configured an HTTPS certificate in Home assistant. This means that your internal URL needs to be set to a domain covered by the certificate”

This is my yaml file for NGINX Home Assistant SSL proxy :

domain: mydomain.duckdns.org
hsts: max-age=31536000; includeSubDomains
certfile: fullchain.pem
keyfile: privkey.pem
cloudflare: false
customize:
  active: false
  default: nginx_proxy_default*.conf
  servers: nginx_proxy/*.conf

My DuckDNS .yaml file config:

domains:
  - mydomain.duckdns.org
token: MYTOKEN
aliases: []
lets_encrypt:
  accept_terms: true
  algo: secp384r1
  certfile: fullchain.pem
  keyfile: privkey.pem
seconds: 300

Port forwarding should be set up OK in Router…
Is there anyone who can help me further?

Hi
I am struggling to get access to HA locally, and I do have fritzbox 7530. Can you elaborate in this please, because I don’t understand what I have to do…

edit: I just read all the posts in this thread, and just realized that this is like a dead thread right now :frowning:

@DavidFW1960 hope you see this.

edit2: I am not sure what happened but I finally made it work… The only thing that is strange is that it finally needs the http: lines in configuration.yaml at least in my case.

Hi, I’ve been running an old, but updated home assistant within docker on an ubuntu headless server.

I’ve set up duckdns and portforwarding on my router and everything works: I can access HA from outside with my phone and android app, also from the inside.

My main problem is that sometimes when I reboot HA or I’ve got a powerloss, I am no longer able to reach HA from the duckdns address because of ssl error even if the ssl is still valid.
But if I check the certs on my server, they are all there in the duckdns and the ssl directory and nothing has changed.
When this happens I still can reach HA from the internall address (https://192.168.1.2:8123) or from the outside using another ddns address I have setup for transmission (obviously changing the port number to the HA one and using https) and accepting the security risk in the browser.
On the duckdns address I only get: Unable to connect to Home Assistant, retrying in XX seconds…

Only solution in this case is erasing the cert from duckdns directory and from the ssl directory and then restarting HA.

What am I doing wrong?

My duckdns setup:
domains:

  • myname.duckdns.org
    token: xxxxxxxxxxxxxxxxxxxxxxxxxxx
    aliases: []
    lets_encrypt:
    accept_terms: true
    algo: secp384r1
    certfile: fullchain.pem
    keyfile: privkey.pem
    seconds: 86400

(yes, the seconds are set to 24 hours, that’s because my IP rarely changes, but had the same problem with standard 300 seconds setting)

configuration.yaml
http:
ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

I see that in the duckdns directory the 2 pem files are linked to the ssl directory.

System\network\ home assistant url addresses both public and local addresses are set to the https duckdns address.

Also tried to change the configuration.yaml ssl address to that of the duckdns directory, but it was not accepted by HA and did not let me restart.

What am I missing?

same issue as Zirowe, after power loss can’t access HA.

I´ve been using nginx and dynu/duckdns for 2-3 years now.
Came across twingate today. Very impressed. Can use 5 ports for free like duck.
Can close all ports on the router.
Set up mfa and policies/users etc. A lot of functionality for a free plan.

Twingate: It’s time to ditch your VPN