DuckDNS only working from own network but not from mobile network

Hey,

so I got some problems with HA and DuckDNS. If I am in my home network I can go to
https://xyz.duckdns.org and it works perfectly also
https://myipadress:8123 does work but http://myipadress:8123 does not as it should be.

However if I try to enter the duckdns website form outside my own network I just get timeout.
I do not use the duckdns addon in HA since I got a static ipv4

Port-forwarding looks like this:

protocol: TCP
port on device: 8123 - 8123
port external (ipv4): 443

Any ideas on how to fix this?

I don’t understand what your port forwards mean how you’ve written them, but it should be protocol ‘both’, external 443 to internal homeassistant device 8123.

yea thats exactly how it is set up

Have you also installed Let’s Encrypt?
Seems like you did since https is working and therefor http doesn’t work anymore (at least, that’s how it’s over here)

What url do you use from outside your LAN?

I set this up a few month ago but than I had to stop using HA I don’t remember if I installed Lets Encrypt is there a way to check?

Form outside my lan I connect (or try to^^) with https://xyz.duckdns.org
I also tried with :8123 and :443 at the end of the adress even through that shouldn’t be necessary

I just started myself with LE+duckdns so not very experienced.
What kind of HA setup do you run?

Is your duckdns domain using your actual WAN IP?

HA is running as VM on windows

Yes duckdns got the right IP otherwise the .duckdns.org adress wound’t work at all not even form the same network :confused:

Have you tried from different foreign networks?
It doesn’t make sense that you can access your HA from your LAN with the duckdns hostname but not from another network.

I know this makes no sense at all

Didnt test that yet and can’t do right now but I’ll do when I am somewhere with open wifi

I’m a bit lost on the different ways and naming for HA setups so just trying…
Is it a supervised setup, do you have an ‘Add-on Store’, there you find info about installed options and in that case about duckdns & let’s encrypt.

Ah okay as said I do not use the DuckDNS addon because there is no need to update the IPv4 adress. I did try turning it on but it doesn’t make any diffrence.

I did not add/use the lets encrypt addon

Maybe it does make sense, does your isp block port 80?

We’ve been forwarding port 443 because of the presumption you would be using encryption, but if you’re not then you need to be forwarding port 80 not 443.

I should also point out though that this is a security risk.

Is there any way to check that? I can’t tell out of the blue

Google your isp name and ‘blocked ports’ or something similar.

Or just try forwarding port 80 and see if that fixes it.

Or, better, stay on 443 and use encryption.

If I google for that nothing shows up so I guess they don’t block it. However I also tried this

telnet yourdomain.com 80

and it shows “can’t connect” but it does so for every port I enter not just 80 and since they can’t block all ports it probably does not mean alot

Right, let’s just go back to the start a minute because there’s something fishy going on here.

In your first post you said you were using https on your internal network and it was working.

For this to be true you must have

  • an internal dns
  • some kind of encryption certificate

Please tell us what internal dns setup you have, and how you’re using encryption locally.

I basically did everything as mentiond in this guide. I don’t know of any internal dns :sweat_smile:

Just started the DuckDNS addon again to make sure that it really isn’t the probelm and it shows this at the end of the log:
problems making Certificate Request

I’m getting confused now, because in that guide they use the duckdns addon and activate let’s encrypt for certificates, but earlier you said that you don’t use the addon :man_shrugging:

I used it but since the ipv4 doesn’t change I turned in off.
IIRC i did get the certificates from Lets encrypt but i never used the Let’s encrypt addon in HA