E-thermostaat | ICY


#41

Yes, I can confirm (after updating to 0.82.1 just now) that the custom component still works.
Please share your redacted config. Did you put the python script in the correct directory?


#42

Hi bram,

I get this message now:
Platform not found: climate.e_thermostaat

homeassistant:

Name of the location where Home Assistant is running

name: ******

Location required to calculate the time the sun rises and sets

latitude: *******
longitude: *******

Impacts weather/sunrise data (altitude above sea level in meters)

elevation: 60

metric for Metric, imperial for Imperial

unit_system: metric

Pick yours from here: http://en.wikipedia.org/wiki/List_of_tz_database_time_zones

time_zone: Europe/Amsterdam

Customization file

customize: !include customize.yaml

Show links to resources in log and frontend

introduction:

Enables the frontend

frontend:

Enables configuration UI

config:

Uncomment this if you are using SSL/TLS, running in Docker container, etc.

http:

api_password: !secret http_password

base_url: example.duckdns.org:8123

ssl_certificate: /etc/letsencrypt/live//fullchain.pem
ssl_key: /etc/letsencrypt/live/
****/privkey.pem
ip_ban_enabled: True
login_attempts_threshold: 5

Checks for available updates

Note: This component will send some information about your system to

the developers to assist with development of Home Assistant.

For more information, please see:

https://home-assistant.io/blog/2016/10/25/explaining-the-updater/

updater:

Optional, allows Home Assistant developers to focus on popular components.

include_used_components: true

Discover some devices automatically

discovery:

Allows you to issue voice commands from the frontend in enabled browsers

conversation:

Enables support for tracking state changes over time

history:

View all events in a logbook

logbook:

Enables a map showing the location of tracked devices

map:

Track the sun

sun:

Sensors

sensor:

Weather prediction

  • platform: yr

E-Thermostaat Icy

climate:

  • platform: e_thermostaat
    username: !secret icy_username
    password: !secret icy_password
    comfort_temperature: 20
    saving_temperature: 15
    away_temperature: 12

Text to speech

tts:

  • platform: google

Cloud

cloud:

SABNzbd

sabnzbd:
api_key: !secret sabnzbd_api
host: ************
sensors:
- current_status

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

the e_thermostaat.py file is in .homeassistant/config/custom_component

kind regards ivo frenken


#44

I think the folder should be custom_components instead of custom_component.
Does that work?


#45

Hi,

Thanks for that information. I got it working today. first I changes the name to custom_components, like freakshock told me. Then I moved the folder from /config to .homeassistant, so to the root folder where the configuration script is.

Kind regards,
Ivo


#46

Hi,

If for some reason this custom component stops working with new HA releases, it is also possible to make it work with MQTT and Node-Red and defining the thermostat as a MQTT climate device in HA. It is a simple interface, you can only get and set the temperature. But who needs the predefined states if you use HA :grinning:


#47

I got it working with the google assistant but it is kind of a dirty fix in the e_thermostaat.py:
STATE_COMFORT = "heat" # "comfort"
STATE_SAVING = "cool" # "saving"
STATE_AWAY = "off" # "away"

Since the google actions api on temperature settings only accepts “off/heat/cool/heatcool/auto” and does not know how to handle “comfort/saving/away” , I changed the values and got it working.

Especially the STATE_SAVING = "cool" # "saving" is not so nice, since you aren’t actively cooling, but I wanted that mode to be available to my Assistant.

Hope this helps


#48

Hi,

I have another question. Has anyone build an automation for this, using the different states (comfort/saving/away/fixed temperature)?

greetings,
ivo Frenken


#49

Yes that works fine. If you are using the version from my Github you have to use the Dutch names though. Here is a working example for the action part of an automation.

action:
  - service: climate.set_operation_mode
    data:
      entity_id: climate.ethermostaat
      operation_mode: Comfortstand

#50

Thnx Tanto, tried it and it works.


#51

Great find, thanks!
@gerard33, perhaps you should change this in your Git, if also fixes the mode changing in Lovelace!
ethermostat


#52

@gerard33, thanks that works


#53

Hi,

There is something strange happening with the automation I have build for the e-thermostat. The action form gerard33 works. But my automation doesn’t It starts at the time I want, but it end before I want it.

It looks like:

  • id: verwarming-aan-weekdagen-ochtend
    alias: Verwarming aan weekdagen ochtend
    trigger:

    • at: ‘05:00:00’
      platform: time
      condition:
  • condition: time
    weekday:

    • mon
    • tue
    • wed
    • thu
    • fri
      action:
      service: climate.set_operation_mode
      data:
      entity_id: climate.ethermostaat
      operation_mode: Comfortstand
  • id: verwarming-aan-weekdagen-ochtend
    alias: Verwarming aan weekdagen ochtend
    trigger:

    • at: ‘05:00:00’
      platform: time
      condition:
    • condition: time
      weekday:
      • mon
      • tue
      • wed
      • thu
      • fri
        action:
        service: climate.set_operation_mode
        data:
        entity_id: climate.ethermostaat
        operation_mode: Comfortstand

I hope someone knows what I’m doing wrong.


#54

Can you post your automation using code block, see the top of the page on how to do this.

And at what time does the thermostat start and end?


#55

This is the code block. I checked this morning, it started at 05:00:00 (comfortstand). then at 05:20:00 it changed to bespaarstand. It should do this at 07:00:00. What can I change to make this happen?

#################################################
#                 Verwarming                    #
#################################################
- id: verwarming-aan-weekdagen-ochtend
  alias: Verwarming aan weekdagen ochtend
  trigger:
  - at: '05:00:00'
    platform: time
  condition:
  - condition: time
    weekday:
    - mon
    - tue
    - wed
    - thu
    - fri
  action:
    service: climate.set_operation_mode
    data:
      entity_id: climate.ethermostaat
      operation_mode: Comfortstand

- id: verwarming-uit-weekdagen-ochtend
  alias: Verwarming uit weekdagen ochtend
  trigger:
  - at: '07:00:00'
    platform: time
  condition:
  - condition: time
    weekday:
    - mon
    - tue
    - wed
    - thu
    - fri
  action:
    service: climate.set_operation_mode
    data:
      entity_id: climate.ethermostaat
      operation_mode: Bespaarstand

- id: '1543219439438'
  alias: Verwarming aan weekdagen middag
  trigger:
  - at: '16:00:00'
    platform: time
  condition:
  - condition: time
    weekday:
    - mon
    - tue
    - wed
    - thu
    - fri
  action:
    service: climate.set_operation_mode
    data:
      entity_id: climate.ethermostaat
      operation_mode: Comfortstand

- id: '1543220075868'
  alias: Verwarming uit weekdagen middag
  trigger:
  - at: '17:30:00'
    platform: time
  condition:
  - condition: time
    weekday:
    - mon
    - tue
    - wed
    - thu
    - fri
  action:
    service: climate.set_operation_mode
    data:
      entity_id: climate.ethermostaat
      operation_mode: Bespaarstand

#56

I see some indents which aren’t right (could be caused by pasting) and I suggest to start the trigger with time.
Can you try it like this?

- id: verwarming-aan-weekdagen-ochtend
  alias: Verwarming aan weekdagen ochtend
  trigger:
    - platform: time
      at: '05:00:00'
  condition:
    - condition: time
      weekday:
        - mon
        - tue
        - wed
        - thu
        - fri
  action:
    service: climate.set_operation_mode
    data:
      entity_id: climate.ethermostaat
      operation_mode: Comfortstand

And can you also check you have disabled all timers and haven’t set a period for the Comfortstand on https://www.e-thermostaat.nl/?


#57

Hi,

I have changed the config. Also I checked if there are any timers on the essent site, but there aren’t. I have set a period for the Comfortstand and that is 90 minutes. So it should not stop after 10 or 20 minutes.

I was thinking if it would be better to make an other trigger. Something like, if the temp is lower than 20 and the time between 05:00:00 - 07:00:00 and weekdays mon - fri. Would that work better?


#58

I’m having the same problem, somehow the thermostat switches back to cooling mode 20 minutes after enabling heating mode in the morning.

I recently started using these modes instead of the ‘Vaste temperatuur’ mode I was using before. I’ll try to switch back and see if this has better results and report back.

Perhaps the settings on e-thermostaat.nl are not actually configured in the hub after changing them, it seems 20 minutes is the default setting to reset to ‘Bespaarstand’


#59

Users of the E-thermostaat received an email this morning explaining that the collaboration between Essent and ICY stops from 1 February 2019. After this, if there is enough interest, ICY will keep it’s services available for €1,95 per month.

More info here:


#60

Too bad, I’m not going to pay 2 euro’s per month just for the service.
Does anyone have a nice alternative to the ICY thermostat that’s affordable (under 100 euro’s), with the same functionality in HA, without a subscription? Preferably with local control?


#61

I am using homematic IP radiator thermostats now, with a selfmade CCU (the homematic control unit) on a rasperry pi, this all local. So I do not use the Homematic IP cloud at all. But it is a bit more expensive, as I use radiator thermostats instead of one central thermostat I need one per radiator. Setting up the rasperry pi as CCU is just a matter of buying the Homematic control kit for rasperry pi and downloading an image.