Echo Devices (Alexa) as Media Player - Testers Needed

alexa
Tags: #<Tag:0x00007f203ea3c770>

#1753

Dear alandtse,
Thank you!
It’s done!


#1754

Since 2 or 3 days ago, a panel appeared named CONFIGURATOR with the following text:
“Alexa Media Player - Begin”
“Please hit confirm to begin login attempt.”

Altough I press confirm and nothing happens. I already deleted the cache, generated a new captcha, but as soon I enter the captcha the same message appears again.


#1755

Since upgrading to the latest version of HA, my Alexa Media Players have disappeared

Anyone have the same problem

Paul


#1756

For me some of the echo dot changed names. Had to adjust my config to reflect the new names


#1757

Thanks for the reply
I had some strange things happen with the upgrade

I rolled back to .86
Then 're installed again and all appears ok so far
Paul


#1758

Did you delete the alexa_media.pickle file in your configuration directory?


#1759

Found the problem, when I tried to enter the amazon website there was a request to change the password for security reasons. As soon I updated the password and changed it on home assistant, everything started working again.


#1760

Is there a way to retrieve the current Alexa Volume level so I can restore previous level after I turn it up for tts or other?


#1761

tried deleting all three files and after updating the captcha, I now have my dots showing up again :slight_smile:


#1762

Sorry I missed that. I’ll give it a shot :slight_smile:


#1763

Is there an updated config for this? I’m trying and failing to get it working. A UK Amazon Alexa user here.


#1764

I’m the UK and this works, note: no quotation marks.

media_player:
  - platform: alexa
    email: !secret amazon_user
    password: !secret amazon_password
    url: amazon.co.uk

#1765

without the " " that the original post outlines?

When I “Check config” it just keeps loading and never says Correct or errors

but when I restart HA, I get a notification saying there’s a problem with my config


#1766

If you only have 1 media player item you don’t need the - before platform.

You can only have one “media_player:” in your config so multiple components get stacked under the one heading.

Like this

media_player:
  - platform: spotify
    client_id: !secret spotify_client_id
    client_secret: !secret spotify_client_secret
  - platform: alexa
    email: !secret amazon_user
    password: !secret amazon_password
    url: amazon.co.uk
    exclude_devices:
      - "Simon's Fire TV stick"
      - "This Device"
      - "Simon's Alexa Apps"

I ALWAYS paste my config into [http://yaml-online-parser.appspot.com/] - It will tell you if any issues with the actual yaml. NOTE: The online parser does not like exclamation marks, I just delete them once I have pasted it.

Are you sure your alexa.py file is correct? In a text editor it should start something like this

"""
Support to interface with Alexa Devices.

For more details about this platform, please refer to the documentation at
https://community.home-assistant.io/t/echo-devices-alexa-as-media-player-testers-needed/58639
VERSION 0.10.1
"""
import logging

from datetime import timedelta

Simon


#1767

Excellent! That revealed a great deal of idiocy on my part. I’d somehow saved the .py file with all the html the webpage contained but have now replaced it and I can see all of my devices.

When I bring up a device (https://imgur.com/a/8vpqC7o) I cannot seem to force any TTS or change the volume. Am I missing something?

EDIT: Since discovered that you have to use media_player.alexa_tts service but even that produced nothing


#1768

Are there release notes? Is there some way to follow what’s new/changed/breaking in new releases?

I love this component and would like to stay up to date. But, you know, I occasionally have to eat, sleep, or go to work and then it’s a forensic investigation to figure out what’s going on.

I’m at 0.9.6.


#1769

No; the commit history helps but we’re not formally keeping release notes. We also were waiting for the wiki to be updated with some examples of how to use the new feature before posting anything here. The main change in 0.10.1 is the addition of the last_called attribute which returns true if that Echo was the last Echo to be verbally used.

We’re using semantic versioning so if you see the middle minor number change, it’s a new feature. The last patch number indicates a bug fix. We’ll probably do a major version change once we break the component apart so we can submit to HA. That will probably break configs.


#1770

@ReneTode
This thread is way too long to read threw it but I found your posting about the useless devices.

Did you find a way the ignore those unneeded devices?
And also I still have that error sometimes.


#1771

Edit your config to add exclusions.


#1772

Im having the same issue here on my end, ever since this last update with Lovelace as the latest UI (0.86.1). Alexa TTS was working perfectly previous to this update, now using the quoted json for service call or json on an automation, I get nothing but silence…