Ecobee Discovery on 99.x

Hello. The first version of HA I began with was 98.5. With it my ecobee thermostats (2) were discovered and setup pretty easily. With the 99.x rollout I had to reinstall HA three or four times while messing up zwave device configuration (never had that working right).

None of those installs seemed to be able to discover my ecobees in the way that 98.5 did. From what I’ve read ecobees aren’t on the discoverable list and there’s a separate config file for them that I neglected to back up. Wondering why ecobees were discoverable before (was it a 98.5 experimental feature) and how I might get them discovered again if possible.

Thanks. -Matt

I don’t see any breaking changes related to ecobee in >0.99 so I’m not sure what would have changed. Can you post your configuration.yaml?

I believe ecobee thermostats are only discoverable via HomeKit Controller which uses zeroconf, which should be enabled by default. You would have entered a HomeKit pairing code in Home Assistant if they were discovered this way. Does that sound familiar?

You can also use the ecobee cloud service to integrate your ecobee into Home Assistant.

Hello. I did enter a pairing code in home assistant to get the ecobees working.

I’ll look into the homekit controller. I do have iphones / ipads. Not sure if they somehow made the ecobees detectable. My configuration.yaml file doesn’t list anything for homekit or ecobee. See below and thanks for the reply:

Configuration.Yaml:


# Configure a default setup of Home Assistant (frontend, api, etc)
default_config:

# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# http:
#   base_url: example.duckdns.org:8123

# Text to speech
tts:
  - platform: google_translate

group: !include groups.yaml
automation: !include automations.yaml
script: !include scripts.yaml

# Example configuration.yaml entry
envisalink:
  host: xxxxx
  panel_type: DSC
  user_name: user
  password: user
  code: 'xxxx'
  port: 4025
  evl_version: 4
  keepalive_interval: 60
  zonedump_interval: 30
  timeout: 10
  panic_type: Police
  zones:
    01:
      name: 'Front Door'
      type: 'opening'
    02:
      name: 'Living Room Motion'
      type: 'motion'
    03:
      name: 'Family Room Motionr'
      type: 'motion'
    04:
      name: 'Bath/Hall Motion'
      type: 'motion'
    05:
      name: 'Mast Bath Door'
      type: 'opening'
    06:
      name: 'Master Bed Door'
      type: 'opening'
    07:
      name: 'Dining Room Door'
      type: 'opening'
    08:
      name: 'Family Room Door'
      type: 'opening'
  partitions:
    1:
      name: 'My House'

# Garage Doors
cover:
  - platform: myq
    username: xxxx
    password: xxxx
    type: chamberlain

# Leviton Switches
light:
  - platform: decora_wifi
    username: xxxx
    password: xxxx

# Smart Life Switches
tuya:
    platform: smart_life
    username: xxxx
    password: xxxx
    country_code: 1

You need to add the following to your config:

ecobee:

Also, if it’s still not working, try removing the ecobee.conf file in your HASS directory and restarting to get the config/set up screen where you’ll need the pin again.

default_config includes what’s needed for HomeKit Controller, you don’t need an iPhone or iPad for it to work. If you paired them to Home Assistant using the HomeKit pairing code, you’ll need to unpair them from HomeKit (either in the ecobee app or on the thermostat itself), then the thermostat should appear in discovery again. Or you need to use the ecobee integration I listed above.

Thanks for the responses Tediore and phantomdarkness.
I unpaired my ecobees, restarted HA and they popped up in the Discovered Integrations page. I don’t have “ecobee:” in my config file and they work fine.

For others, I used these instructions to reset my ecobees:

How to reset your Ecobee3 HomeKit connection

    Go to your Ecobee3 thermostat and tap on the Main Menu button (the three lines in the lower left corner).
    Scroll down to Settings and tap on it.
    Scroll down to Reset and tap on it.
    Tap on Disconnect from HomeKit.
    After the warning, tap on the Yes button.

Glad to hear they’re working. To clarify, you only need ecobee: in your config if you want to integrate your thermostats using ecobee’s cloud service. It’s not required if you pair them in the way that you did (which is also the way I have mine paired).