Emulated hue - Bridge not discoverd, no entities exposed

emulated_hue.yaml:

listen_port: 80
host_ip: 192.168.181.111
advertise_ip: 192.168.181.111
expose_by_default: false
lights_all_dimmable: true
exposed_domains:
 - light
# - media_player
# - scene
# - lock
 - switch
# - cover
entities:
  switch.schaltsteckdose:
    name: "Testschalter"
    hidden: false
---------------------------

http://192.168.181.111/description.xml:

-----------------------------------
<root xmlns="urn:schemas-upnp-org:device-1-0">
<specVersion>
<major>1</major>
<minor>0</minor>
</specVersion>
<URLBase>http://192.168.181.111:80/</URLBase>
<device>
<deviceType>urn:schemas-upnp-org:device:Basic:1</deviceType>
<friendlyName>Home Assistant Bridge (192.168.181.111)</friendlyName>
<manufacturer>Royal Philips Electronics</manufacturer>
<manufacturerURL>http://www.philips.com</manufacturerURL>
<modelDescription>Philips hue Personal Wireless Lighting</modelDescription>
<modelName>Philips hue bridge 2015</modelName>
<modelNumber>BSB002</modelNumber>
<modelURL>http://www.meethue.com</modelURL>
<serialNumber>001788FFFE23BFC2</serialNumber>
<UDN>uuid:2f402f80-da50-11e1-9b23-001788255acc</UDN>
</device>
</root>
------------------------------------------------------------

http://192.168.181.111/api/pi/lights:

--------------------------------------------
{"1": {"state": {"on": true, "reachable": true, "mode": "homeautomation", "bri": 254}, "name": "Testschalter", "uniqueid": "00:b6:8a:10:90:b8:f3:99-16", "manufacturername": "Home Assistant", "swversion": "123", "type": "Dimmable light", "modelid": "HASS123"}}
------------------------------------

But! https://discovery.meethue.com/:

-----------------------------------
[{"id":"ecb5fafffe055c90","internalipaddress":"192.168.181.150"}]
------------------------

This is only my dedicated Hue Bridge, not the emulated one.
Neither Bridge is discoverd, nor entitiie is exposed.

log:
2020-11-30 08:09:22 INFO (MainThread) [homeassistant.setup] Setting up emulated_hue
2020-11-30 08:09:22 INFO (MainThread) [homeassistant.setup] Setup of domain emulated_hue took 0.0 seconds

I try now for many many days, can’t get it work.
Someone got a hint for me.

Is alexa on the same subnet as the emulated hue bridge?

Yes. Two Echo dots and two Alexa Apps in the same subnet.
192.168.176.0/21
255.255.248.0

homeassistant 192.168.181.111
echo dot1 192.168.181.160
echo dot2 192.168.181.161
echoFlex1 192.168.181.162

If i try to connect the emulated hue via HUE Essentials i get a error “missing name field”. I dont know if this is related.

I know from discussions around “habridge” that alex has a very large “cache problem”… ahving multiple echoes on the same network, deleting devices, rediscovering etc…

To be honest, I have no clear answer. What you can try is to delete go to “alexa.amazon.com” and try from there. Restart homeassistant, power down all echoes and only use 1 at a time to discover…

That’s all I know…

I tried disconnecting all alexa devices, add some more entities to emulated_hue.yaml, rebooted HA, powerde up one alexa device.
Nothing shows up in alexa when searching for new devices.
I’m out of ideas.


> `{"3": {"state": {"on": true, "reachable": true, "mode": "homeautomation", "bri": 254}, "name": "Diele_hell", "uniqueid": "00:19:d8:a2:e8:24:1b:5a-ec", "manufacturername": "Home Assistant", "swversion": "123", "type": "Dimmable light", "modelid": "HASS123"}, "4": {"state": {"on": true, "reachable": true, "mode": "homeautomation", "bri": 254}, "name": "Klo", "uniqueid": "00:75:5d:70:52:de:84:f8-51", "manufacturername": "Home Assistant", "swversion": "123", "type": "Dimmable light", "modelid": "HASS123"}, "1": {"state": {"on": true, "reachable": true, "mode": "homeautomation", "bri": 254}, "name": "Testschalter", "uniqueid": "00:b6:8a:10:90:b8:f3:99-16", "manufacturername": "Home Assistant", "swversion": "123", "type": "Dimmable light", "modelid": "HASS123"}}`

I have exactly the same issue. Have you finally managed to solve it?

did you ever figure this out?

Anyone ever managed to solve this? Have the exact same problem…

I tried any configuration I could find, but had no success with Alexa finding the bridge.
Furthermore I tried GitHub - hass-emulated-hue/core: Hue Emulation for Home Assistant. Here I got to a point, where the bridge was found by the third party app “Hue essentials”, but still could not be added neither there nor in Alexa
(same issue as here: Emulated Hue + Hue Essentials = "Missing conditions field!" · Issue #43222 · home-assistant/core · GitHub).

After 6+ hours of fiddling, I ended up configuring the Alexa Smart Home skill in ~40 minutes: