Emulated Hue not finding devices

Hey All,

Not sure what the issue is here but I can’t seem to rediscover my devices. I started to notice they were duplicating in the Alexa app so I went in (alexa.amazon.com) and chose Forget All.

When I went back to rediscover it found all the echo devices and hue bulbs but nothing more. I have an assortment of echo device versions so I disconnected all but my gen 1 echo. Read there may be issues where others try to take over.

After I set this up I tried to rediscover by voice to the echo and also in the app by adding a new device then selecting other. I found older threads similar to mine but none of the solutions worked or weren’t applicable.

I am able to get to the xml page as well as the /api/lights and see all of my devices. Any automations or scripts that I have set up are still firing for example door sensors where alexa alerts that door is open etc. Just can’t speak commands because she can’t see the devices.

At a loss here, anyone have any thoughts?

Thanks Guys

Can you post the emulated hue section of your config… also maybe some of the output from the xml page maybe we can compare to see if something is different/missing

Sure thing. Couple things to add is that I’m on the latest version of HA and no changes have been made to my config.

XML

<root xmlns="urn:schemas-upnp-org:device-1-0">
<specVersion>
<major>1</major>
<minor>0</minor>
</specVersion>
<URLBase>http://192.168.1.95:8300/</URLBase>
<device>
<deviceType>urn:schemas-upnp-org:device:Basic:1</deviceType>
<friendlyName>HASS Bridge (192.168.x.x)</friendlyName>
<manufacturer>Royal Philips Electronics</manufacturer>
<manufacturerURL>http://www.philips.com</manufacturerURL>
<modelDescription>Philips hue Personal Wireless Lighting</modelDescription>
<modelName>Philips hue bridge 2015</modelName>
<modelNumber>BSB002</modelNumber>
<modelURL>http://www.meethue.com</modelURL>
<serialNumber>1234</serialNumber>
<UDN>uuid:2f402f80-da50-11e1-9b23-001788255acc</UDN>
</device>
</root>

config

emulated_hue:
  host_ip: 192.168.x.x
  expose_by_default: true
  exposed_domains:
    - light
    - switch
    - media_player

what do you get from this…

http://<HA IP Address>:8300/api/pi/lights

You’ve probably exceeded the max number of devices. Using true here exposes absolutely everything, your automations, scripts, switches, input_booleans etc. If these total over forty-something (which even the most basic setup usually does) then it won’t work.

1 Like

That would make sense… I at one time could not get my devices showing and ultimately setting it to false and explicitly listing each device with “hidden: false” is how I managed to get them showing. Never realized it was due to a device limit, thanks for that info.

Thanks,

I now understand what that does. Unfortunately no progress. I just left

  • switch
  • media_player

Try just exposing a single entity just to test the theory, create an input_boolean to test

input_boolean:
  alexa_test:

And expose only that and see if Alexa can pick it up…

emulated_hue:
  host_ip: !secret host_ip
  expose_by_default: false
  entities:
    input_boolean.alexa_test:
      name: "Test"
      hidden: false
1 Like

Thanks again for helping out, this worked. My only issue is that I don’t want to have to add all of these manually. Just not sure why it stopped working all of a sudden.

I suspect your switch domain has too many entities.

Expose_by_default the other domains you want and be selective on the switches entity by entity would be where I would start.

Will do, i’ll try some testing and see what i can get to work.

1 Like

So I started out small (with media_player) because i know i am no where near 49…nothing. However now my api/pi/lights are now showing nothing. Howerver, I am in the middle of segmenting my network into trusted devices and IoT devices so im wondering if that is starting to play a role. The description.xml is showing normally however.

I’ll report back as i do some more testing. Thanks again for your guys’ help.

1 Like

Ok, I got my network stuff sorted out and confirm that I can see everything via homeassistant. XML is showing as well as the /api/pi/lights.

{"106": {"modelid": "HASS123", "name": "Daryn's Alexa Apps", "state": {"bri": 255, "hue": null, "on": true, "reachable": true, "sat": null}, "swversion": "123", "type": "Dimmable light", "uniqueid": "media_player.daryn_s_alexa_apps"}, "113": {"modelid": "HASS123", "name": "Office", "state": {"bri": 33, "hue": null, "on": true, "reachable": true, "sat": null}, "swversion": "123", "type": "Dimmable light", "uniqueid": "media_player.office"}, "114": {"modelid": "HASS123", "name": "Bedroom", "state": {"bri": 255, "hue": null, "on": true, "reachable": true, "sat": null}, "swversion": "123", "type": "Dimmable light", "uniqueid": "media_player.bedroom"}, "115": {"modelid": "HASS123", "name": "Loft", "state": {"bri": 255, "hue": null, "on": true, "reachable": true, "sat": null}, "swversion": "123", "type": "Dimmable light", "uniqueid": "media_player.loft"}, "34": {"modelid": "HASS123", "name": "Samsung TV Remote", "state": {"bri": 0, "hue": 0, "on": false, "reachable": true, "sat": 0}, "swversion": "123", "type": "Dimmable light", "uniqueid": "media_player.samsung_tv_remote"}, "40": {"modelid": "HASS123", "name": "Everywhere", "state": {"bri": 255, "hue": null, "on": true, "reachable": true, "sat": null}, "swversion": "123", "type": "Dimmable light", "uniqueid": "media_player.everywhere"}, "41": {"modelid": "HASS123", "name": "This Device", "state": {"bri": 255, "hue": null, "on": true, "reachable": true, "sat": null}, "swversion": "123", "type": "Dimmable light", "uniqueid": "media_player.this_device"}, "42": {"modelid": "HASS123", "name": "Daryn's Echo", "state": {"bri": 255, "hue": null, "on": true, "reachable": true, "sat": null}, "swversion": "123", "type": "Dimmable light", "uniqueid": "media_player.echo"}}

So my question would be this. In the event that I went over the 49 devices did that screw something up? I cant see any other reason this wouldn’t be working. The warning on the Emulated Hue page states:

Warning: If you have a lot of devices (more than 49 total across all exposed domains), you should be careful with this option. Exposing more devices than Alexa supports can result in it not seeing any of them.

This is what I am seeing. Right after that it says try disabling this and try specifying a few at a time to see if it fixes it (which works for me). Right now I just have the media_player set up for testing. As we saw earlier I have been able to add entities separately but can no longer add the domain “group”.

Since my last post I have deregistered all of my echos and dots and re-added them. I currently have the original Echo along with 2 second gen dots and a 3rd gen dot.

What I’ve tested:

Removing all echo’s except for the original - didnt find any devices
Tried on both ports 80 and 8300. Both show xml and lights - didnt find any devices
Tried both true and false for exposed_by_default - didnt find any devices

Thanks again for any info you can provide.

I am now at a real loss for why this is not working. I got busy and didnt have time to mess with this but have picked it back up just recently. I have completely rebuilt HomeAssistant. Emulated Hue was the first thing I added with 1 light as a test. I set the expose_by_default to false. Both XML and /api/pi/lights load correctly with the latter just having the one entity I specified. I have tried voice discovery, app discovery, web (alexa.amazon.com) discovery and none work.

My Echo Devices
Gen 1 Echo
Gen 1 Echo Dot
Gen 2 Echo Dot
Gen 3 Echo Dot

Any Suggestions?

Thanks All

Are you discovering them as generic devices or gen 1 hue devices? Also, I can’t remember but I recall needing upnp.

Chances are, this is 100% related to your network and it has nothing to do with your emulated hue setup.

There are a few gotcha’s with emulated hue.

  1. Everything must have a unique friendly name. I think you have this covered.
  2. Bridge 1 hue’s have a device limit. It’s not 49, it’s somewhere in the 60s. I currently have 55. I remember reading on the hue forums, that they have a limit of 63. Everyone on this forum assumes that if you go over 63, that this will not work. I cannot confirm this but I believe it’s true.
  3. You must have at least 1 gen 1 or gen 2 echo/dot on your network.
  4. Your devices must IMMEDIATELY report a change after a command is sent.

All other recommendations are just hit and miss. There are plenty of posts on this forum that have people trying many different things.

Thanks Petro,

I’m tending to agree with you pertaining to UPnP. I’ve segmented my network into Trusted and IoT devices and use an EdgeRouter X as my router. I was looking into the UPnP settings on it last night ater i sent this because i believe I came across another thread you had commented in that suggested this. I’ll see what i can do and report back.

Thanks!

I was having this same issue during the 0.97 beta testing. You aren’t running a beta install by any chance?

I’m not. It’s the full install.

Yeah, that guy who made the PR doesn’t realize that the issues lies in his hardware not responding to alexa. I’m glad You posted something about this. At least balloob reverted the changes. I just hope that guy isn’t persistent. I don’t really feel like rolling back a component every update.

Initially he owned up to it being his code causing the problem and then started telling me it was my environment. I have 4 gen 3 echo dots and purposely kept a gen 2 in situ as I believe it is still recommended.