Enable MQTT?


#1

I installed the hassbian image and i see it says that the MQTT broker is disabled by default. How do i go about turning it on and making it run at boot?


#2

Here’s the tutorial I followed from BRUH Automation on youtube, worked well for me just tried it last week: https://www.youtube.com/watch?v=AsDHEDbyLfg


#3

Check the MQTT docs.


#4

I have the same problem.
For all that don’t know there is a image for raspberry pi called hassbian that has HS installed and some other components, one is MQTT.
Problem is is not active Question is how do you activate it???
I tried few options but no success yet.
matt i deed fallow Ben’s video but no result since mqtt is already installed and changing configuration didn’t help.

IKROWNI if you find a way to make it work please let me know.
All the best


#5

Is not a integration problem MQTT is not active it come with the image but is not active no idea how to activate it.


#6

I sent a message to the developer hope he can point us in the right direction.


#7

Yea I ended up jumping back to the full Jessie image and got HA to successfully install finally. The problem I am having now is that HA isn’t seeing mqtt. I can send messages and receive messages by opening 2 putty instances but HA does not want to see it for some reason.


#8

if you installed the all in one installer you have to set the password and user in to all your devices. ex i use a pir sensor with esp 8266 so you have to change the sketch to have password and username. i use an app for android called mqtt dashboard that connects to my servers and sees all the messages sent and received.


#9

Just received this message from Fredrik Lindqvist (the developer):
It’s actually installed as a service and should be able to be
activated/started with “systemctl start mosquitto”.To have it running on
boot you could/should also do “systemctl enable mosquitto”. The default
install of Mosquitto has no password set so anyone/thing can connect.
I don’t have a instance running where I’m at right now but I’ll double
check this tomorrow and augment the documentation to reflect this.
If there’s anything else missing I’ll happily try to add it.


#10

Funny i spent all day trying to fix it and only think i had to do is to send this command: sudo systemctl start mosquitto
Well is working fine


#11

I’ve been using Arduino as an MQTT node and the HBMQTT broker, but for my HASS be able to receive and send the messages, I has to download the netdisco and netifaces libraries for python. After that it worked fine for me.


#12

I have the some issue unable to connect ot the Mosquitto on Hassbian. Within the SSH it works fine. But when I use MQTT.fx it does not connect. Here is the SSH respond:


Any help would be appreciated. Thanks!


#13

For anyone else that lands here using hassbian - I was able to setup mosquitto by using sudo hass-config install mosquitto


#14

Thanks to all who came before me. I’m surprised this isn’t better documented. I just came to let you all know that on the newest Hassbian images the proper command is:

sudo hassbian-config install mosquitto

though it doesn’t like me using sudo so I have to use
su
first and then just
hassbian-config install mosquitto

Happy MQTTing!