Enter/Exit Zone using only iBeacons


#1

Hi

I’m trying to configure the Hass beta app such that I can only enter/exit my home zone using iBeacons.

Currently I have the following config:

zone:
  - name: Home
    latitude: lat
    longitude: lon
    radius: 60
    icon: mdi:home
    passive: true

homeassistant:
  customize:
    zone.home:
      beacon:
        uuid: B4B70026-66F7-C401-7FFB-F88DFAE528F6
        major: 0
        minor: 0

But it does not seem to allow me to enter the home zone, does anyone know if it is still possible to enter a passive zone using iBeacon or is there another way to achieve this?

Also does anyone know how the app handles setting major and minor to 0? I would assume that it would match any beacon with the specified uuid, no matter the major and minor of that beacon.


#2

That’s pretty much exactly what I wanted to do, you should check out the ‘monitor’ project by andrewjfreyer. It worked perfectly for me, just a hint, beacons work best with the beta build.

Monitor


#3

Your config is correct what are your app settings?

There’s an update available for the beta app (v29) have a look in the testflight app.

I just updated and got an ibeacon notification for the first time.


#4

@tom_l Are you only entering and exiting the zone using iBeacons?

I still can’t get it to work, I suspect that it is because of the passive zone, but as I don’t want to enter/exit the zone using GPS I can’t really remove that flag.

Any chance you could post your config for the zone and customization for the beacon?


#5

Yes.

- name: 'Home'
  latitude: !secret home_lat
  longitude: !secret home_long
  radius: 50

zone.home:
  track_ios: true
  # passive: true
  beacon:
    uuid: E2C56DB5-DFFB-48D2-B060-D0F5A71096E0
    major: 0
    minor: 0

#6

Still not working here:

zone:
  - name: Home
    latitude: !secret home_lat
    longitude: !secret home_lon
    radius: 30
    icon: mdi:home

homeassistant:
  customize:
    zone.home:
      track_ios: true
      beacon:
        uuid: B4B70026-66F7-C401-7FFB-F88DFAE528F6
        major: 0
        minor: 0

I even tried reinstalling the app.
Here are my app settings