Error doing job: Task exception was never retrieved | TypeError: object tuple can't be used in 'await' expression

Hi,

I am trying to install Home Assistant on Freebsd via pip. I get the following error when I try to launch home assistant with hass --ignore-os-check -v -v -v -v:

2024-02-29 11:48:18.891 INFO (SyncWorker_1) [homeassistant.loader] Loaded spotify from homeassistant.components.spotify
2024-02-29 11:48:18.889 ERROR (MainThread) [homeassistant] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/datastorage/homeassistant/lib/python3.9/site-packages/homeassistant/helpers/discovery_flow.py", line 71, in _async_start
    await gather_with_concurrency(
  File "/datastorage/homeassistant/lib/python3.9/site-packages/homeassistant/util/async_.py", line 203, in gather_with_concurrency
    return await gather(
  File "/datastorage/homeassistant/lib/python3.9/site-packages/homeassistant/util/async_.py", line 201, in sem_task
    return await task
  File "/datastorage/homeassistant/lib/python3.9/site-packages/homeassistant/data_entry_flow.py", line 229, in async_init
    flow, result = await task
  File "/datastorage/homeassistant/lib/python3.9/site-packages/homeassistant/data_entry_flow.py", line 256, in _async_init
    result = await self._async_handle_step(flow, flow.init_step, data, init_done)
  File "/datastorage/homeassistant/lib/python3.9/site-packages/homeassistant/data_entry_flow.py", line 374, in _async_handle_step
    result: FlowResult = await getattr(flow, method)(user_input)
  File "/datastorage/homeassistant/lib/python3.9/site-packages/homeassistant/components/brother/config_flow.py", line 85, in async_step_zeroconf
    self.brother = await Brother.create(
  File "/datastorage/homeassistant/lib/python3.9/site-packages/brother/__init__.py", line 95, in create
    await instance.initialize()
  File "/datastorage/homeassistant/lib/python3.9/site-packages/brother/__init__.py", line 121, in initialize
    _, errstatus, errindex, _ = await get_result
TypeError: object tuple can't be used in 'await' expression
^E^C2024-02-29 11:49:49.084 INFO (Recorder) [homeassistant.components.recorder.pool.RecorderPool] Pool recreating

Any idea what I can do about it?

Solved.

I forgot what exactly fixed it though. Perhaps I needed to install sqlite3. Possibly pyopenssl, I forgot to note it.