Error in log about mobile app

Hey guys,

I could solve the first error, used "value" as a variable in a template, where I shouldn't

A few weeks ago I started seeing the following error in my logs:

Logger: homeassistant.components.websocket_api.http.connection.140202140659376
Source: core.py:1262
Integration: Home Assistant WebSocket API (documentation, issues)
First occurred: 1:32:35 (1 occurrences)
Last logged: 1:32:35

expected float for dictionary value @ data['value']
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/websocket_api/commands.py", line 125, in handle_call_service
    await hass.services.async_call(
  File "/usr/src/homeassistant/homeassistant/core.py", line 1262, in async_call
    processed_data = handler.schema(service_data)
  File "/usr/local/lib/python3.8/site-packages/voluptuous/validators.py", line 208, in __call__
    return self._exec((Schema(val) for val in self.validators), v)
  File "/usr/local/lib/python3.8/site-packages/voluptuous/validators.py", line 287, in _exec
    raise e if self.msg is None else AllInvalid(self.msg, path=path)
  File "/usr/local/lib/python3.8/site-packages/voluptuous/validators.py", line 283, in _exec
    v = func(v)
  File "/usr/local/lib/python3.8/site-packages/voluptuous/schema_builder.py", line 272, in __call__
    return self._compiled([], data)
  File "/usr/local/lib/python3.8/site-packages/voluptuous/schema_builder.py", line 817, in validate_callable
    return schema(data)
  File "/usr/local/lib/python3.8/site-packages/voluptuous/schema_builder.py", line 272, in __call__
    return self._compiled([], data)
  File "/usr/local/lib/python3.8/site-packages/voluptuous/schema_builder.py", line 594, in validate_dict
    return base_validate(path, iteritems(data), out)
  File "/usr/local/lib/python3.8/site-packages/voluptuous/schema_builder.py", line 432, in validate_mapping
    raise er.MultipleInvalid(errors)
voluptuous.error.MultipleInvalid: expected float for dictionary value @ data['value']

I never really cared to look into this, because everything worked and I had no idea where to start.

Now / a few days ago, the error below started to appear, and as you can see in the timestamps, they come up ~1 min after each other (while I usually don’t have anything else in the logs):

Logger: homeassistant.components.mobile_app.webhook
Source: components/mobile_app/webhook.py:132
Integration: Mobile App (documentation, issues)
First occurred: 1:31:20 (1 occurrences)
Last logged: 1:31:20

Received invalid webhook payload: value is not allowed for dictionary value @ data[9]['type']. Got ''

Does anyone else see this or is this a configuration mistake on my side?

Thank you very much for any help!

this is what we see when the app is trying to send data back to HA, which app is this?

Excuse me, I should’ve mentioned that. I use the android beta.

Wait for the latest beta that should be live tonight or tomorrow and yet again please. If you still get an error open a bug on GitHub so we can get it looked into

1 Like

Perfect, I will do that. Thank you!

I went to the sensor settings in the app (before the update), clicked on some of them (had to authorize 1 or 2). The error is now gone!

1 Like