Error in log regarding a component which was never installed

Sometimes I observe an error in the log:

Logger: custom_components.hacs
Source: custom_components/hacs/repositories/integration.py:63
Integration: HACS (documentation, issues)
First occurred: 04:04:39 (1 occurrences)
Last logged: 04:04:39

<Integration custom-components/sensor.custom_aftership> No file found 'custom_components/custom_aftership/manifest.json'

I believe this is about some custom integration.
But I have never installed an integration looked like this, it is not present in my “custom_components” folder.
What is this?

HACS is trying to parse all manifest.json files of onboarded custom components and had an issue while parsing this specific custom repository. You can try to reach owner of custom component about the issue or ask for removal from HACS

But I do not have this component installed!
And I have never installed it.

You have HACS right? The error is coming from HACS, not from any other component.

fwiw, I started seeing the same error - appears solved by redownloading HACS and restarting HASS:
image