Error message first time trying Home Assistant (OSX)

Hi,

Im just starting to explore the Home Assistant world. I have installed it onto my iMac for testing. I get an error message saying;

2017-10-10 18:05:46 ERROR (SyncWorker_1) [homeassistant.util.package] Unable to install package netdisco==1.2.2: Command “/Library/Frameworks/Python.framework/Versions/3.6/bin/python3.6 -u -c “import setuptools, tokenize;file=‘/private/var/folders/kn/wh_8c8mj7f98w0q1m6gm9rnr0000gn/T/pip-build-c_w2886_/netifaces/setup.py’;f=getattr(tokenize, ‘open’, open)(file);code=f.read().replace(‘\r\n’, ‘\n’);f.close();exec(compile(code, file, ‘exec’))” install --record /var/folders/kn/wh_8c8mj7f98w0q1m6gm9rnr0000gn/T/pip-cznts8k1-record/install-record.txt --single-version-externally-managed --prefix --compile --user --prefix=” failed with error code 1 in /private/var/folders/kn/wh_8c8mj7f98w0q1m6gm9rnr0000gn/T/pip-build-c_w2886_/netifaces/
2017-10-10 18:05:46 ERROR (MainThread) [homeassistant.setup] Not initializing discovery because could not install dependency netdisco==1.2.2
2017-10-10 18:05:46 ERROR (MainThread) [homeassistant.setup] Setup failed for discovery: Could not install all requirements.

Can anyone help me with this? I have tried searching the forum and web, but have yet not found any solution…

see the note at the end of this page:

I have tried it, didt work.

But, I found a solution;
I had to install the developer tools to my mac, even tough the video instructions on installing on mac says the opposite.

Now it works :+1:t3: