Error on Update to 6.1 -> 7.6

Attempting to update to OS v7. Shut down the VM first and restarted it fresh. Update fails and I get the “Unknown error, see supervisor” message.

Supervisor log says:

22-04-18 18:08:11 ERROR (MainThread) [supervisor.os.manager] Home Assistant Operating System update failed with: Installation error: Failed updating slot kernel.1: failed to mount slot: failed to run mount: Child process exited with code 32

Not sure where to go from here.

I too have this problem. Identical supervisor log message, updating from 4.16 to 7.6.

Same issue.

Same issue, 6.0 → 7.6

Anyone find a solution yet?
Note that CLI approach of ha os upgrade fails with same error. Restarting supervisor does not help.

A workaround that worked for me is - do the OS update in two steps: First to 6.6 and then to latest.

ha os update --version=6.6

and then

ha os update

Hat tip @agners.

@doron - Thank you! Can confirmed this worked.

Upgrading from 4.16 to 7.6 was successful, with intermediate upgrade steps.

The process that worked was upgrade to 4.20, then 5.13, then 6.6, then 7.6.