Error: 'os-agent_1.5.1_linux_x86_64.deb' is not a Debian format archive - corrupted downloads?

Hi, I’m confused by a problem I’m having trying to install the OS Agent. This manifested itself as the “not a Debian format archive” error shown at the bottom of this post. But the actual issue is that the downloads seem to be corrupt every time.

In the command sequence below, you can see that 2 different downloads result in files with different checksums; neither being the right one. Given I’ve tried this on two different machines at my end I’m thinking that whatever is serving these files is messed up?

Or have I missed something?

I’ve also tried downloading older versions of the agent, and get exactly the same problem.

$ sha512sum os-agent_1.5.1_linux_x86_64.deb 
246b4fb46ebb6841181c250b022b77ecef3623dfb41c8a3b8f1674883b2e841949094978be2229579b2ad531e240c1a993fdc83d6dccb1bd9d83a5f77a520197  os-agent_1.5.1_linux_x86_64.deb

$ rm os-agent_1.5.1_linux_x86_64.deb 

$ wget https://github.com/home-assistant/os-agent/releases/tag/1.5.1/os-agent_1.5.1_linux_x86_64.deb
--2023-04-17 11:30:45--  https://github.com/home-assistant/os-agent/releases/tag/1.5.1/os-agent_1.5.1_linux_x86_64.deb
Resolving github.com (github.com)... 140.82.121.4
Connecting to github.com (github.com)|140.82.121.4|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: ‘os-agent_1.5.1_linux_x86_64.deb’

os-agent_1.5.1_linux_x86_64.     [ <=>                                           ] 113.11K  --.-KB/s    in 0.07s   

2023-04-17 11:30:46 (1.64 MB/s) - ‘os-agent_1.5.1_linux_x86_64.deb’ saved [115829]

$ sha512sum os-agent_1.5.1_linux_x86_64.deb fc151037656fe510d3fa5deed6b85342a51079b51a6b30036b44129ca67ac2687f146b399ed4c4ceaec2f92e71599024477019fa4ede8d80f1fa0b20eccb6508  os-agent_1.5.1_linux_x86_64.deb
$ sudo dpkg -i os-agent_1.5.1_linux_x86_64.deb
dpkg-deb: error: 'os-agent_1.5.1_linux_x86_64.deb' is not a Debian format archive
dpkg: error processing archive os-agent_1.5.1_linux_x86_64.deb (--install):
 dpkg-deb --control subprocess returned error exit status 2
Errors were encountered while processing:
 os-agent_1.5.1_linux_x86_64.deb

OK, just in case anyone else has this problem. Don’t take the instructions too literally. I was using:

wget https://github.com/home-assistant/os-agent/releases/tag/1.5.1/os-agent_1.5.1_linux_x86_64.deb

instead of:

wget https://github.com/home-assistant/os-agent/releases/download/1.5.1/os-agent_1.5.1_linux_x86_64.deb

1 Like