Error service switch/turn_on switch/turn_off on python 3.7.4

Tags: #<Tag:0x00007f3f2b3abb20>

Hello, since I migrated to python 3.7.4, the service switch / turn_on switch / turn_off with the xiaomi plugs does not work. I’m using the xiaomi gateway.
I get this error:
“Error al llamar al servicio switch/turn_on . /usr/lib/arm-linux-gnueabihf/libssl.so.1.1:version `OPENSSL_1_1_1’ not found (required by /srv/homeassistant/lib/python3.7/site-packages/cryptography/hazmat/bindings/openssl.at)”

1 Like

What is your setup? Hassbian or docker?

Hi, I do not have hassbian, so I guess it’s docker.
I installed in a virtual space of Python, I have raspbian as an operating system.

If it is so, you should look for update/upgrade your system. In particular of openssl.

If it won’t solve, you might have the chance to migrate your HA to a new setup.

Thanks you!!!, as I use raspbian, I guess I have to install a new version of it, is not it? Or maybe I can update OpenSSL only ?.
For now I have activated Python 3.5 3 again, and recovered the old version of HA, but of course, this is not appropriate.

So you should need another SDcard and prepare the newest version on that one. In case of faults it will take less than a minute to revert to working condition.
For what I know, you might have look to the Armbian, which delivers a decent updated version.
Then you may opt to install home assistant by the use of pip. Last step it will just take to migrate your configuration there.

First of all, thank you very much, the problem was exactly what you said.
I’ve valued Armbian, but I’m a bit scared, I do not know the system, I do not know how it will go in a Raspi.
I have Raspbian strech installed, and I have thought about the fastest option, which would be to download OpenSSL 1.1.1 for debian and install it, without further ado, but I am afraid that there is some incompatibility. I know that raspbian buster supports it, but I would not like to change the s.o. because it would mean reinstalling a lot of software.
Do you know if Raspbian strech supports OpenSSL 1.1.1 and if it could be installed without further ado?

I’m on Asus Tinker Board :stuck_out_tongue: So for your case the option leading to get a new SD card, clone your actual system and go for the updates. If it will fail just plug the clone back to the RPi. That’s the safest way you should try.

The clone it is a matter of a row byte copy. This document may give some guideline, except for those strictly related to TB.
Just see what is necessary to do about dd.

Have you solved it? I’m in the same shoes. Installed python 3.7 because of the HA start error message now Xiaomi devices with tokens do not work

ImportError: /usr/lib/arm-linux-gnueabihf/libssl.so.1.1: versionOPENSSL_1_1_1’ not found (required by /srv/homeassistant/lib/python3.7/site-packages/cryptography/hazmat/bindings/_openssl.abi3.so)`

Solution for me:
before python update I backed up original environment, and just copied back this folder to the new environment, restarted HA and now it starts without error and lamps/fan/vacuum works properly.

/srv/homeassistant/lib/python3.7/site-packages/cryptography/hazmat/bindings/_openssl.abi3.so

No, I still have not solved it, I’m installing everything in a new microsd, but I have the project on standby, I’ll take it back over the weekend.
I may try your solution if it works fast.
Than you!