Error : Task exception was never retrieved

Hi guys,
I’m getting this error on my home-assistant.log, everything was working fine. Don’t have any idea of what could it be ?

2020-12-28 09:06:15 ERROR (MainThread) [homeassistant] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 130, in async_init
    result = await self._async_handle_step(
  File "/usr/src/homeassistant/homeassistant/", line 213, in _async_handle_step
    result: Dict = await getattr(flow, method)(user_input)
  File "/usr/src/homeassistant/homeassistant/helpers/", line 318, in async_step_discovery
    return await self.async_step_pick_implementation()
  File "/usr/src/homeassistant/homeassistant/helpers/", line 243, in async_step_pick_implementation
    return await self.async_step_auth()
  File "/usr/src/homeassistant/homeassistant/helpers/", line 267, in async_step_auth
    url = await self.flow_impl.async_generate_authorize_url(self.flow_id)
  File "/usr/src/homeassistant/homeassistant/helpers/", line 147, in async_generate_authorize_url
    redirect_uri = self.redirect_uri
  File "/usr/src/homeassistant/homeassistant/helpers/", line 131, in redirect_uri
    raise RuntimeError("No current request in context")
RuntimeError: No current request in context

Have the same error! No idea what could cause that, but still wanted to let you know that you’re not alone.

1 Like

I’m also seeing this error in a clean setup that I started to configure today. Unfortunately I have no additional information to add.

@quoccuongit1992 @B_lex

Do you guys use the spotify integration by any chance? After removing it a few days ago, the error hasn’t reappeared for me.

hi @m1ke , it’s work. :laughing:, I dont know whats going on there

Thanks @M1ke, that worked for me as well! I will add the Spotify integration again later this week and see if I can figure out what is going on.