Error when compile .yaml file whit ESPHome

220/5000

Hi all, this is my first post.
I have been using Home Assistant for a few months, but suddenly something started to go wrong.
I am going crazy to try to understand what causes this compilation error (the same file in the past was compiled without errors).

Thanks for your help.

INFO Reading configuration /config/esphome/t_cameraest.yaml…
INFO Generating C++ source…
INFO Compiling app…
INFO Running: platformio run -d /config/esphome/t_cameraest
Processing t_cameraest (board: d1_mini; framework: arduino; platform: [email protected])

HARDWARE: ESP8266 80MHz, 80KB RAM, 4MB Flash
Looking for ESPAsyncTCP-esphome library in registry
Warning! You are not connected to the Internet.
If you build a project first time, we need Internet connection to install all dependencies and toolchains.
Warning! You are not connected to the Internet.
If you build a project first time, we need Internet connection to install all dependencies and toolchains.
Dependency Graph
|-- 1.0
|-- 1.2
| |-- 1.0
Compiling /data/t_cameraest/.pioenvs/t_cameraest/src/esphome/components/api/api_connection.cpp.o
Compiling /data/t_cameraest/.pioenvs/t_cameraest/src/esphome/components/api/api_server.cpp.o
Compiling /data/t_cameraest/.pioenvs/t_cameraest/src/esphome/components/api/list_entities.cpp.o
Compiling /data/t_cameraest/.pioenvs/t_cameraest/src/esphome/components/api/subscribe_state.cpp.o
In file included from src/esphome/components/api/api_connection.h:7:0,
from src/esphome/components/api/api_connection.cpp:1:
src/esphome/components/api/api_server.h:19:25: fatal error: ESPAsyncTCP.h: No such file or directory


  • Looking for ESPAsyncTCP.h dependency? Check our library registry!
  • CLI > platformio lib search “header:ESPAsyncTCP.h”
  • Web > PlatformIO Registry

#include <ESPAsyncTCP.h>
^
compilation terminated.
*** [/data/t_cameraest/.pioenvs/t_cameraest/src/esphome/components/api/api_connection.cpp.o] Error 1
In file included from src/esphome/components/api/api_server.cpp:1:0:
src/esphome/components/api/api_server.h:19:25: fatal error: ESPAsyncTCP.h: No such file or directory


  • Looking for ESPAsyncTCP.h dependency? Check our library registry!
  • CLI > platformio lib search “header:ESPAsyncTCP.h”
  • Web > PlatformIO Registry

#include <ESPAsyncTCP.h>
^
compilation terminated.
*** [/data/t_cameraest/.pioenvs/t_cameraest/src/esphome/components/api/api_server.cpp.o] Error 1
In file included from src/esphome/components/api/subscribe_state.h:47:0,
from src/esphome/components/api/subscribe_state.cpp:1:
src/esphome/components/api/api_server.h:19:25: fatal error: ESPAsyncTCP.h: No such file or directory


  • Looking for ESPAsyncTCP.h dependency? Check our library registry!
  • CLI > platformio lib search “header:ESPAsyncTCP.h”
  • Web > PlatformIO Registry

#include <ESPAsyncTCP.h>
^
compilation terminated.
*** [/data/t_cameraest/.pioenvs/t_cameraest/src/esphome/components/api/subscribe_state.cpp.o] Error 1
In file included from src/esphome/components/api/list_entities.h:52:0,
from src/esphome/components/api/list_entities.cpp:1:
src/esphome/components/api/api_server.h:19:25: fatal error: ESPAsyncTCP.h: No such file or directory


  • Looking for ESPAsyncTCP.h dependency? Check our library registry!
  • CLI > platformio lib search “header:ESPAsyncTCP.h”
  • Web > PlatformIO Registry

#include <ESPAsyncTCP.h>
^
compilation terminated.
*** [/data/t_cameraest/.pioenvs/t_cameraest/src/esphome/components/api/list_entities.cpp.o] Error 1
========================== [FAILED] Took 3.21 seconds ==========================

Hello, do you use the latest version of esphome? If not update.
There was an issue in previous version.

To help others help you, please:

  1. Please format your post so that the output from the build is in code blocks. You can use the icons at the top of the editor when editing your post
  2. Include your yaml file in code blocks as well
  3. Confirm you’re on the internet when compiling. Looks like you’re not

Thanks eXtatic, now I,ve the version 1.14.4 of ESPHome and so I’m able to compile: no errors.
Thanks a lot again.

There’s a button under each post for making a topic solved (select the one that helped). You don’t have to edit the title.

Sorry, I’m learning.
Regards