Error with clean install of HassOS

So, yesterday I was trying to work on HADashboard and discovered that somehow my install had become corrupt and about 80% of my components no longer worked. Well, I tried everything and still couldn’t fix things, so I had to do a completely new install of Hassio (resin-hassio-1.3-raspberrypi3.img.bz2). Now, however, I’m getting an odd error: " Message incorrectly formatted: expected str for dictionary value @ data[‘api_password’]. Got None" and I cannot figure out why. I’m using a secrets file so my entry in the config file is:

http:
# Secrets are defined in the file secrets.yaml
api_password: !secret http_password
# Uncomment this if you are using SSL/TLS, running in Docker container, etc.
# base_url: example.duckdns.org:8123

I’m also getting a lot of “Connection lost. Reconnecting” messages.

I am also trying to install the latest version of the HassOS based Home-Assistant (0.75.0 and 0.75.1). Between the Hass.io Dashboard not being available (Error: “Unable to load the panel source: /frontend_es5/compatibility.js”) and the incredible number of “Connection lost. Reconnecting” messages (nearly every second), I’ve had to punt to backup.

Yeah, I’m having nothing but problems now. It won’t stay connected at all. Unfortunately for me because my last install went corrupt somehow I don’t have a backup to go back down.