"Error with media stream contents" - Camera stream unstable / blinking fir generic camera entity

Hi there,

I have an issue on by Dashboard tablet where when I click my IP camera icoin to display the stream, the picture is unstable and blinking.
In fact, the stream is displayed, but unstable due to an error message appearing and disappearing several times a second.

Message says “Error with Media stream contents”, as you can see below.
It makes the monitoring impossible ;-(

the dashboard is using the following code :

            entity: camera.192_168_1_5
            tap_action:
              action: call-service
              service: script.launch_cam_rue_tablet_screen_300_dupliquer
              target: {}
              mode: restart
            name: Rue
            primary_info: name
            icon_type: entity-picture
            fill_container: true
            secondary_info: none
          - type: custom:mushroom-entity-card
            card_mod:
              style: |
                ha-card {
                  background: transparent;
                  border: 0px;
                }

… and this script “script.launch_cam_rue_tablet_screen_300_dupliquer” is the following :

alias: Launch cam Rue + tablet screen 300 (Dupliquer)
sequence:
  - service: number.set_value
    data:
      value: "300"
    target:
      entity_id: number.lenovo_tab_m10_plus_3rd_gen_screen_off_timer
    enabled: true
  - service: browser_mod.popup
    data:
      title: Caméra Extérieure
      dismissable: false
      content:
        camera_view: live
        type: picture-glance
        entities: []
        camera_image: camera.192_168_1_5
      timeout: 300000
      size: fullscreen
      browser_id:
        - Lenovo-tablette
      right_button: Fermer
  - delay:
      hours: 0
      minutes: 5
      seconds: 0
      milliseconds: 0
  - service: number.set_value
    data:
      value: "30"
    target:
      entity_id: number.lenovo_tab_m10_plus_3rd_gen_screen_off_timer
    enabled: true
mode: parallel
icon: mdi:cctv
max: 10

(It is just displaying the live strem of my IP camera 192.168.1.5 but change the parameter of the tablet timeout first).

The camera.192.168.1.5 entity is a generic camera and gives the exact same blinking issue when displaying the entity …, here is its configuration :

Any idea how I can display a stable picture of it ?
Many thanks !!!