ESP has been flashed with wrong flash size

No matter what I tried, I could not connect to my Sonoff Basic R2 and upload my ESPHome config. I therefore did a manual download and uploaded it using ESP8266Flasher. The device came online and I could add it to HomeAssistant and use it.

However when I now try to update it over the air, I get

ERROR Error binary size: Error: ESP has been flashed with wrong flash size. Please choose the correct ‘board’ option (esp01_1m always works) and then flash over USB.

The board is set to esp01_1m.

ESP8266Flasher has the following config:
Flash size: 4MByte
SPI Mode: DOUT

What other flash size should I try for the initial ESP8266Flasher upload?
image

Sonoff basic has only 1M of flash, if i remember correctly - did you try that?
4M of flash have usually by default only ESP32 boards.
BTW…i always flash my esp8266 with tasmotizer. The best tool for those boards (for win - i hope there’s a mac version also)

Awesome, Tasmotizer did the trick :slight_smile: Many thanks. I think you are right, 1M would have worked but did not feel like playing around if Tasmotizer is the better option :sunny:

1 Like