ESP Home BLE Tracking

HI, I have been trying to get BLE tracking working, I get it working but the default 300 second
delay makes it pretty useless, when I try to change this to 10 seconds the ESP Home editor gives an error on the scan interval line. What Am I doing wrong?

Thanks

captive_portal:

# Enable logging
logger:

# Enable Home Assistant API
api:

ota:
  port: 8266  
  
# Bluetooth Tracker          
esp32_ble_tracker:
  scan_interval: 10s 




binary_sensor:
  
  - platform: ble_presence
    mac_address: C5:68:04:6A:0C:F5
    name: "Tracker John"

What error are you getting?

I get a red cross next to the line number in the editor on the line with scan_interval and it wont let me upload to the esp

If you hover on the red cross you get an error message.

Ahhh !! I didnt know that. It says The option was removed as it didnt have any effect. Do you know the best way of speeding up the scan by ant chance?

Presumably the interval option in the docs

Yep tried that, all the parameters listed throw up variuos errors. Not sure what is going on…

None of which you post here.

I found the problem
the syntax should be

scan_parameters:
Interval: 10s

Not as I had above.
scan_interval: 10s
Thanks for your prompting me to try out the various settings

regards John

As I said above.