ESPHome 2022.11.xx bluetooth issues

I have a generic ESP32 running ESPHome. I set it up initially in October with 2022.10.1 and installed the bluetooth proxy, which detected several thermostats (flashed to BTHome). I also installed a custom component called powerpal_ble, which reads electricty usage data from a BT device.

I updated ESPHome several times, however when 2022.11.1 came out, it no longer built. I fixed this issue as it related to the older version of ble_client which powerpal_ble required, however I now find that I have several major issues. I’ve since updted to 2022.11.4 hoping that would resolve the problem but it doesn’t seem to. I have not really changed the config since the October version.

My BTHome devices seem to have really spotty connections now. I had 4 around the house including 1 outside, and they all were read from frequently. Now they only seem to connect if they are very close to the device. Additionally, the powerpal_ble component does not read at all from the powerpal device.

I wondered if it was the ESP32 device itself, so I tried with another ESP32 I have, with the same results.

Of course I briefly tried in vain to downgrade ESPHome but I learnt that’s not possible, sadly.

Are there are additional steps I could try here to work out what’s going on?

It’s known problem, supposely it will be corrected in 2022.12 version. For now your options are either go back to 2022.10.x or wait for 2022.12 version.

Or use the dev version which can be installed parallel to the stable releases via HA addons. There is also a beta but by the looks of it 2022.12 isn’t packed yet :package:

1 Like

Hm… i installed dev version on my HA (via HACS). Dev version didn’t start (stuck at "starting nginx9, so i removed it, but now i can’t even start stable version. Now what? I removed stable version, restarted HA… still same - stuck at “starting nginx”…
EDIT: ok, force-restart of complete VM in Synology helped. Now stable version is ok, so i won’t touch dev version anymore…

Hm… I never got anything esphome related from HACS. I wasn’t even aware that HACS could “ship” add-ons - always thought it is limited to integrations and components. :man_shrugging:

Any way I didn’t had any troubles in the past having stable, beta and dev installed in parallel (they share the same yaml files btw. which can be quite handy). :muscle:

Well - that’s actually the last line of the log when everything is as expected. :+1:

I quite confident that wasn’t esphome add-on related at all but rather something to do with HA (maybe ingress). Many people have problems with getting add-ons to work after restoring a backup for example and a full restart normally fixes that :arrows_counterclockwise:

Thank you @Protoncek, can I ask where you read / learnt this? I’d prefer to not hassle the community when the answers are already out there :slight_smile:

First: sorry, i messed up - it wasn’t via HACS, but through system – addons store. My mind was too “full” when i wrote above lines…

You’re correct, “starting nginx” is last line when esphome starts, too. But in my case addon didn’t start - when i tried to open “ESPHome” page i’ve got “addon is not running” message, also in addons section it was clear that it doesn’t run, since word “RUN” was there to click (but nothing happened when i clicked on it).
I agree that this was probably just “hiccup” from HA… honestly, i didn’t restart VM with dev version, but only HA (many times). I restarted VM only when i couldn’t start stable version anymore and i used all my knowledge in solving problem.
But, now i have one thing more in my head for solving potential problems: restarting VM, so i learned something new.

I do have test HA installation also, maybe i’ll play with dev version there, just of out curiosity. But not on production HA anymore. I should done that in the first place. I learned my lesson…

I created a ticket on esphome’s github when i’ve got problems. I don’t have exact link now, i’ll try to find it later…
EDIT: found it: HERE

@Protoncek do you know how to do this? I didn’t think it was possible to revert to an earlier version of an addon…?

Just restore a esphome (dashboard) add-on backup. As it’s seperated from your yaml files it essentially just downgrades your esphome version to the one in your backup :white_check_mark:

Aahh… yes, you see I don’t have a backup from back then… No other solutions?

Just install the beta?

This seems to be working a bit better but it still seems spotty. Does anyone know if there’s a way to improve the signal?

Better antennas :satellite: on both sides or just bringing receiver & sender closer together and getting rid of obstacles :signal_strength:

For BT proxy i only use ESP32 modules with external antenna - works way better than small PCB one.