ESPHome doesn't show Update button while the Add-On Store shows a newer version - How to update?

I’ve been using ESPHome for a while and have many integrations relying on the components that run ESPHome.

On the Dashboard, I see the ESPHome version that I’m currently using.
image
It is version 1.17.2. There is no ‘Update’ option or indication that I can click.

When I look in the Add-on Store, I see a newer version:
image
If I click on it, it gives met the ‘Install’ option.

Obviously, I don’t dare to press Install, because I’m afraid it could cause a conflict. And if I would uninstall the current version that I’m running now, I’m afraid I’ll loose all the work I’ve done on the running instances.

Is there a way I can force the current version to upgrade to the latest and greatest? Or is there a procedure to uninstall the current one and install the new one without loosing any of my integrations and source-files?

Thanks in advance!!

What repository is esphome using now ?

Can you please tell me where I can see that?

This is what the Log of ESPHome says:

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] 00-banner.sh: executing…

Add-on: ESPHome
ESPHome Hass.io add-on for intelligently managing all your ESP8266/ESP32 devices.

Add-on version: 1.17.2
You are running the latest version of this add-on.
System: Home Assistant OS 6.4 (armv7 / raspberrypi4)
Home Assistant Core: 2021.9.6
Home Assistant Supervisor: 2021.09.0

Please, share the above information when looking for help
or support in, e.g., GitHub, forums or the Discord chat.

[cont-init.d] 00-banner.sh: exited 0.
[cont-init.d] 01-log-level.sh: executing…
[cont-init.d] 01-log-level.sh: exited 0.
[cont-init.d] 10-requirements.sh: executing…
[cont-init.d] 10-requirements.sh: exited 0.
[cont-init.d] 20-nginx.sh: executing…
[cont-init.d] 20-nginx.sh: exited 0.
[cont-init.d] 30-esphome.sh: executing…
[cont-init.d] 30-esphome.sh: exited 0.
[cont-init.d] 40-migrate.sh: executing…
[cont-init.d] 40-migrate.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[22:51:48] INFO: Waiting for dashboard to come up…
[22:51:48] INFO: Starting ESPHome dashboard…
INFO Starting dashboard web server on unix socket /var/run/esphome.sock and configuration dir /config/esphome…
[22:51:50] INFO: Starting NGINX…
INFO 304 GET / (0.0.0.0) 214.87ms
INFO 304 GET /static/fonts/material-icons/material-icons.css?hash=ead4c276 (0.0.0.0) 66.52ms
INFO 304 GET /static/css/vendor/materialize/materialize.min.css?hash=ec1df3ba (0.0.0.0) 11.37ms
INFO 304 GET /static/css/vendor/materialize-stepper/materialize-stepper.min.css?hash=f4d254e9 (0.0.0.0) 12.20ms
INFO 304 GET /static/css/esphome.css?hash=50406740 (0.0.0.0) 12.62ms
INFO 304 GET /static/js/vendor/jquery/jquery.min.js?hash=12108007 (0.0.0.0) 14.48ms
INFO 304 GET /static/js/esphome.js?hash=b418707c (0.0.0.0) 3.61ms
INFO 304 GET /static/js/vendor/materialize/materialize.min.js?hash=4be20daf (0.0.0.0) 10.26ms
INFO 304 GET /static/js/vendor/jquery-ui/jquery-ui.min.js?hash=cab3392d (0.0.0.0) 14.29ms
INFO 304 GET /static/js/vendor/jquery-validate/jquery.validate.min.js?hash=aad785d4 (0.0.0.0) 14.19ms
INFO 304 GET /static/js/vendor/materialize-stepper/materialize-stepper.min.js?hash=ef217c59 (0.0.0.0) 14.83ms
INFO 304 GET /static/js/vendor/ace/ace.js?hash=65322f49 (0.0.0.0) 9.56ms
INFO 304 GET /static/fonts/material-icons/MaterialIcons-Regular.woff2 (0.0.0.0) 12.20ms
INFO 304 GET /static/js/vendor/ace/theme-dreamweaver.js (0.0.0.0) 16.69ms
INFO 304 GET /static/js/vendor/ace/mode-yaml.js (0.0.0.0) 24.72ms
INFO 101 GET /ace (0.0.0.0) 28.47ms
INFO Running command ‘esphome --dashboard -q /config/esphome vscode --ace’
INFO 200 GET / (0.0.0.0) 56.38ms
INFO 200 GET /static/fonts/material-icons/material-icons.css?hash=ead4c276 (0.0.0.0) 5.87ms
INFO 200 GET /static/css/esphome.css?hash=50406740 (0.0.0.0) 3.56ms
INFO 200 GET /static/css/vendor/materialize/materialize.min.css?hash=ec1df3ba (0.0.0.0) 10.67ms
INFO 200 GET /static/js/vendor/jquery-validate/jquery.validate.min.js?hash=aad785d4 (0.0.0.0) 21.28ms
INFO 200 GET /static/js/vendor/materialize/materialize.min.js?hash=4be20daf (0.0.0.0) 29.71ms
INFO 200 GET /static/css/vendor/materialize-stepper/materialize-stepper.min.css?hash=f4d254e9 (0.0.0.0) 28.27ms
INFO 200 GET /static/js/vendor/jquery-ui/jquery-ui.min.js?hash=cab3392d (0.0.0.0) 37.28ms
INFO 200 GET /static/js/vendor/jquery/jquery.min.js?hash=12108007 (0.0.0.0) 13.59ms
INFO 200 GET /static/js/vendor/materialize-stepper/materialize-stepper.min.js?hash=ef217c59 (0.0.0.0) 15.08ms
INFO 200 GET /static/js/vendor/ace/ace.js?hash=65322f49 (0.0.0.0) 15.88ms
INFO 200 GET /static/js/esphome.js?hash=b418707c (0.0.0.0) 4.91ms
INFO 200 GET /static/fonts/material-icons/MaterialIcons-Regular.woff2 (0.0.0.0) 5.51ms
INFO 200 GET /static/js/vendor/ace/theme-dreamweaver.js (0.0.0.0) 16.78ms
INFO 200 GET /static/js/vendor/ace/mode-yaml.js (0.0.0.0) 17.94ms
INFO 101 GET /ace (0.0.0.0) 1.86ms
INFO Running command ‘esphome --dashboard -q /config/esphome vscode --ace’
INFO 304 GET / (0.0.0.0) 20.63ms
INFO 101 GET /ace (0.0.0.0) 2.03ms
INFO Running command ‘esphome --dashboard -q /config/esphome vscode --ace’

There is the add-on from Home Assistant Community Add-ons
image

There are the add-ons from ESPhome :

Possibly you still have an older repository

Anyway, you can uninstall the old one (save a snapshot) and reinstall any without losing anything.

1 Like

Great, thank you!
I’ll try it right-away (created a snapshot earlier today, just to be sure).

It worked!

I did an Uninstall of the ESPHome that was running, did an Install of the new version directly after it (without rebooting) and it started working straight-away with all my ESP-configuration intact.

Thanks again!

PLEASE use code tags.

I’m running ESPHome in my own Docker Container for which the web UI shows updates are available. Within that UI I can click the triple dots next to a device and Install > Wirelessly; however, there are no “Update” buttons associated to any of my ESPHome entity in Home Assistant. I’ve removed a ESPHome device and re-added it (IP address, Port, Key) and the sensors appear again, but still no update button / status.

Any suggestions?