Esphome editor is acting out

Hello all,

I have been experiencing a weird issue which I am sure has a simple solution but I can’t figure it out. I click on the EspHome tab on the left side on the dashboard. There I see all the esp devices I have setup. Until a few days ago, I could just click on the device and select Edit and modify the yaml.

Well today things changed, I click on the device and select Edit and then the screen turns white and I can’t see the yaml file. I can’t make it work anymore. What is happening. I see nothing in the logs.

Lucian

What browser you are using? Did you try some other?

tried chromium and firefox. I have cleaned the data and cookies from each browser several times but that didn’t work.

Try uninstalling esphome and install back. It doesn’t loose data, will load your configurations automatically.

just reinstalled… now I get a black screen and cannot even see the devices… at least they seem to work!

What is happening?

Maybe at this point it is good idea to take a full backup of your system. At minimum copy the esphome folder from your configuration folder to somewhere else.
image

What is the HW you are running on? And how did you install it (on top of debian, HAOS…).

Is it only ESPhome and not any other addon/page on your installation?

I have HA running in a virtual machine in proxmox. The only major change that happened lately was me changing the server hardware to a lower power cpu. But HA has 4 cores and 16 gb ram and the overall load of the CPU with all the VMs is about 10% so resources shouldn’t be a problem.

After the update all was working. I have noticed this problem while working with a particularly stubborn esp32 I got from aliexpress. I have it setup with bluetooth-proxy and it was acting up big time. Freezing, restarting itself etc. It is then I noticed that I couldn’t access the Esphome editor and now the page.

Another thing I did was to try to downgrade esphome to 11.5 version because some people on this forum were saying that this solved some stability problems with the bluetooth proxy. but that didn’t quite work for me so I updated back to the latest version.

I should wait for a new uptate?

try removing conf for that particular ESP under the esphome folder.

And then all of them and try to access the add on page.

I ran out of further ideas to try. I have no knowledge how proxmox works either.

After reloading the esphome dashboard several times I got this error in the browser:

Unable to load the panel source: /api/hassio/app/entrypoint.js.

What does that mean?

figured it out! what a doozie!

So I am using an nginx reverse proxy to access HA. Well the nginx VM storage space was full to the brim! that caused the access problems! The problem was the nginx access log for HA. Deleted that, restart nginx and bam! Full access again!

1 Like