ESPHome Ethernet connectivity feature request

This is the one that I bought:

combined with the W5100 ethernet shield

This is the board:

The W5100 Ethernet shield carries the following chip:

Which I don’t think works with esphome

type ( Required , string): The type of LAN chipset. Must be one of LAN8720 or TLK110 (see datasheet for more details).

I think you got the answer for me.
I will use it then as a WIFI board.
Thank You

I was willing to replace my Arduino wired alarm system whereas the sketch that I have is not totally stable. This seemed an ideal replacement. I will need to live either with a WIFI alarm system or try one of the other boards indicated on the ESPhome website.

Settings for WT32-ETH01

ethernet:
type: LAN8720
mdc_pin: GPIO23
mdio_pin: GPIO18
clk_mode: GPIO0_IN
phy_addr: 1
power_pin: GPIO16

1 Like

Is it working with ESPHOME?

Is what working with ESPHOME?

Wired Ethernet? Yes it does.

Nice. How many digital I/O are available on this board? It’s a good candidate for replace my alarm ESP32

Thanks so much for posting this! :grinning:
I’d been tearing my hair out trying the get mine working, using the examples in ESPHome and various permutations, and had just about given up hope.
Now it is working on wired ethernet!!

Anyone can confirm that WT32-ETH01 is working with HA and ESPHOME ?
If so, are there any particular activities to load initial code or just connect to LAN and use OTA from ESPHOME plugin ?

Tak Maciek działa, przecież podałem ustawienia parę postów wyżej.

1 Like

I think you’ll have to make the first firmware upload over serial in the usual way.

It seems so. And as it does not have USB port there needs to be wired connection to Rx/TX pins + USB-RS232 converter

English please.

Hello,

I have received some WT32-ETH01 boards today and trying to get them up and running with ESPHome and HA.

At the very top of the YAML there is an entry for ‘board:’

What board type have others specified here for their WT32-ETH01s?

Thanks,

J

I am using

board: esp-wrover-kit

This works fine. :grinning:

Ok cool, thanks.

So my YAML starts like this:

esphome:
  name: watercontrols
  platform: ESP32
  board: esp-wrover-kit

ethernet:
  type: LAN8720
  mdc_pin: GPIO23
  mdio_pin: GPIO18
  clk_mode: GPIO0_IN
  phy_addr: 1
  power_pin: GPIO16


captive_portal:

# Enable logging
logger:

But it complains…

image

If i add a wifi component in it also complains that Wifi cant be used with Ethernet :frowning:

Any suggestions?

Thanks,

Joel.

I found my problem - i just needed to delete:

captive_portal:

I haven’t actually been able to control anything yet but making progress!

Thanks,

J

Are you usinig the WT32-01 board? It does not use the WROVER module and some of the GPIO do not match.

Currently ESPHOME can’t support this module because nobody has created a platformIO profile for it.

I have ESPHome working w/ this module, but most of the GPIO labels are “off”.

If i look at the pin out for the ESP32 module on the WT32:

http://www.wireless-tag.com/wp-content/uploads/2020/08/WT32-S1-DataSheet-V1.1.pdf

(page. 20)

Compared to the pinout for the esp-wrover-kit:

You can see that things don’t quite match up. I’m trying to do it manually, but it’s error-prone and time consuming.

Tasmota has support for the module, but I don’t know how to map the templates back to the actual GPIO labels on the board / ESP32 module. If i knew this, then it would be possible to build a “look up table” so you can use the board: esp-wrover-kit w/ ESPhome while a proper module is built.

EDIT Actually, it does appear that the GPIO from the wt32-01 and the esp-wrover-kit match pretty closely… at least for my purposes. However there’s still some odd behavior; the WT32 module has a pin labeled GPIO1 but it appears to not be connected to any of the pins on the ESP32 module. Likewise, GPIO3 seems to be always high and i can’t seem to control it.

So the esp-wrover-kit will work with ESPHome, but it’s not a proper/complete solution.

1 Like