Fail to enable ssh to HassOS host os

I have just installed HassOS 3.7 with Home Assistent 0.103.5 on a RPI3.
Since I have 1wire sensors connected to the RPI I wanted to add support for 1wire sensors.

  • I found this link for preparations. It tells me to enable ssh to the host OS via port 22222 by adding ssh public key to the PI.
  • I have followed the instructions in link to generate public and private keys.
  • I have created a file authorized_keys in which I copied the public key, copied the file to USB stick called CONFIG formatted with NTFS which I inserted into the RPI.
  • In Home Assistent->Hass.io-> Host System I pressed Import from USB.
  • In Putty I created a session to my RPI IP and port 22222 in which I imported the private key generated above. I get the following error from putty:
    putty
  • I did try to do exactly as described and I have tried in several ways.
    I saw that there is a ssh server add-on. I know it can’t be used for the purpose above but I thought I could try the ssh keys.
    I installed the add-on, configured it with the same keys as was generated above. It worked directly so I assume I at least succeeded with generating the ssh keys.

For now I suspect that authorized_keys is not correctly updated. If I look in the System log after pressing the Import from USB I can see this:

20-01-03 10:12:12 INFO (MainThread) [hassio.hassos] Syncing configuration from USB with HassOS.
20-01-03 10:12:12 INFO (MainThread) [hassio.host.services] Restart local service hassos-config.service
20-01-03 10:12:12 INFO (MainThread) [hassio.utils.gdbus] Call org.freedesktop.systemd1.Manager.RestartUnit on /org/freedesktop/systemd1

It does not mention the file I want to be copied to my RPI.

Anyone that has a suggestion for me?

1 Like

Hi, did you solved this?? I have the same problem…
Tks

1 Like