Failing at first hurdle - no web ui- Pi4 with 4GB with

Okay, made the decision to start using Home Assistant. Bought a brand new Pi 4 with 4Gb.
Followed the instructions on the HA site for downloading and installing the Raspberry PI 4 32 and 64 bit images. The instructions say that the downloand and install is the hard bit - if only!

Pi is connected to an hdmi screen and on connecting power I can see the start up messages scrolling by.
Checked on my router and could see a ‘hassio’ entry and an ip addres.

Started a continuous ping from a different machine against the address and apart from the one drop for every 9 pings it all looks good.

Waited patiently for the 20 minutes or so for the web page to come up. Tried many variants of the address but kept getting connection refused. Port scans also showed no ports open.

Tried downloading and reinstalling and get the same. About 5 minutes after reboot it settle down to just telling me the wlan0 link is not ready and power management has been disabled every few minutes.

Logged on through the console to the hassio prompt and tried a few things eg ‘hassio info’ which tells me to use 'hassos not ‘hassio’. Okay ‘hassos info’ says ‘Get http://hassio/hassos/info: dial tcp connect: connection refused’ - Not sure what this implies.

Tried logging into the underlying OS and saw that the date/time is December 18! Not Sept 2019.

Tried to locate logs in /config - not such directory!

Currently running the V3.5 64bit version of but seen similar on 32 bit version.

Any obvious ways forward?


the 20 minutes thing is based on your internet speed. It could take longer (it used to take nearly an hour for my slow internet to download new docker images). Also, you should be able to just scan port 8123 (that’s the only one you will get an interface on), and if your router doesn’t support mDNS, then you will have to use the IP to connect.

Thanks, actually left it overnight last night. 40mbs download speed at the router and the Pi is cable Ethernet attached not Wi-Fi.

Using in the address bar of the browser on a windows 10 PC on the same network.

I was scanning all ports because I couldn’t Putty to the Pi either. Port 22 isn’t showing as open on the Pi.

By default, SSH isn’t enabled. HassOS is an appliance, not normal Raspbian. There is also no “pi” user.

If you want to enable SSH in the OS, you need to look at the documentation and set up the SDCard with your key.

You can also login and check status of the docker containers to see if they are running. There are also Docker logs.

Just tried and getting a positive ping response back from and So guess internet connection is okay.

i had a similar experience installing the same new Rpi4 and 32bit beta image. Couldn’t be found, so I had no idea which Ip address it had, to reach it, or to install other necessary add-ons.

My Asus-router didnt show it either, which was a first.

I then tried one of my network scanners on the iPhone, and it was recognized immediately. Entering the ip adress it found followed by the port :8123 then launched it all. Quickly added the SMB and SSH add-ons, and running fine afterwards.

So, try to find it on your mobile device and see what happens?

I have been running the port scan using an app in my ipad. It can ping the Pi but no ports found.

I think I will have a got at the Hassbian route instead and see if that works.

May I ask what device you are booting from on your Rpi4?

a regular sdcard 128gb

And I am running a regular 32gb so card.

FYI I have now installed Hassbian and that is working as expected.

I was just about to suggest that. I’m running HA in a venv and don’t have the issues you outlined above. Of course the perceived wisdom here is so who am I to question that wisdom. The main thing is you’re up and running with HA and that’s all that matters.

My pi4, 4Gb experience is the same. Hassio never shows up with either the 32 bit or 64 bit image, using a 32Gb SD card and USB. Tried with USB and WiFi network file. Tried without USB and Ethernet connection.
Hassbian on the other hand loads fine. But without add-on feature of Hassio, I am finding it too cumbersome to figure out how to get EspHome or Tasmoto going. Also, added MQTT to Hassbian, but hit the finish button, and subsequently unable to find how to add those options. All internet searches lead to pi3 users running Hassio. “Just use the add-on”, which Hassbian does not have.
I assume the Hassio file was tried on a pi4 and found to work before the image was loaded. I can only conclude the loaded file is corrupted or the instructions miss something. I have found absolutely no one who has installed the Hassio image on a pi4 successfully. I am running out option with Hassbian. Maybe Open Hab?

I should add, as two of you have succeeded. Gives me hope. I’ll download again (in case my file is corrupted) and try again.

I would suggest following the alternative install instructions for

Install Rasbian Lite and then insta

You also then have the option of running it all from a USB SSD and greatly increasing the reliability.

Thank you
3rd time is a charm. Maybe I missed something, but it installed ok this time. Used a different card, who knows. Anyway, I may do what you suggest as this hassio also does not give putty/SSH access without some key loops. Another reason to do as you suggest. I’ve noted the link.
As an aside, same issue on initial setup. Once I hit the highlighted “Finish”, I can’t seem to get back to those options.
I will endeavor to explore, must be some way to get at them.
I have much to learn.

I just started down the same path with the PI4 and cannot get past the web page saying “Preparing Home Assistant with the blinking blue dot” and left it run over night and it never gets past this status. I have tried re-flashing 2 times the 64 bit image with no improved result. I am curiously about the “3rd time is a charm”. Are you saying that the hassio installed properly and is now working?
Also eelier in this message chain, there was mention of an alternative install instructions for Where can I find this procedure?