Failure to start HassOS on VMware ESXi with "Object type requires hosted I/O" error

After a power failure, ESXi wasn’t able to start the “official” VMDK-based HassOS with the error “Object type requires hosted I/O”. It seems VMDK gets corrupted and this fine blog post cleaned in it up:

Note that 100% of the comments on this blog post as of 29-Jan-2021 are, in fact, all about Home Assistant. There seems to be a pattern emerging. I am new around here, so … how do we go about figuring this out and fixing it permanently?

Had the same issue after a long power outage here as well. All other VMs recover fine, but the Home Assistant one fails and needs manual recovery. It’s not the first time this happens…

I finally found a solution for this. Stop the VM, and check the drive images…

vmkfstools -x check "hassos_ova-3.10.vmdk"

If it says “Disk needs repaired” (which mine did), then repair it.

I dont think repair implies the disk image is damagaed, it just implies that some disk config is not as it should be

> vmkfstools -x repair "hassos_ova-3.10.vmdk"
Disk was successfully repaired

Now we need to convert the disk image to VMFS, since it was created from a desktop version of VMWare and the disk image does not support snapshots…

> vmkfstools -i "hassos_ova-3.10.vmdk" "hassos_new-3.10.vmdk"

Destination disk format: VMFS zeroedthick
Cloning disk 'hassos_ova-3.10.vmdk'...
Clone: 100% done.

Now unregister the hassos_ova-3.10.vmdk disk from your hassos VM Image (do not delete the files just yet)

Attach the newly converted hassos_new-3.10.vmdk image leaving the settings as default

Fire up your VM. You may find the vm refuses to boot, but skip past this with F1

You may get a 2nd warning suggesting the disk may need partioning. Ignore this and hit ‘m’ to boot into the menu like it suggests

At this point it boots you into the ha shell prompt and after a little while home assistant should be up and running

Once you have checked everything is working, you can delete the old disk image hassos_ova-3.10.vmdk (there may be secondary images such as hassos_ova-3.10-s001.vmdk which can be deleted also)

You can now use snapshots on your HA VM, aswell as use any VM backup tools which rely on snapshot feature (such as Synology Backup For Business)

If you find it’s not working, just delete the new drive from the VM config and reattach the old vmdk, and you are back to where you started.

Credit to Solved: Error when create a VM snapshot - Object type requ... - VMware Technology Network VMTN


I am running HA in a VM on ESXI 6.5 and ran into the exact problem described here. Everything works great until unexpected power failures, had to do the “repair vmdk” trick every single time! You’re clone to VMFS procedure worked like a champ! To speed up the boot afterwards, I only needed to go into the VM’s bios and adjust the boot order to place the newly attached vmdk first, after that, it was smooth sailing, thanks a million!

Just FYI, restoring a (recent) snapshot will also work :wink:

Hi dankrill, can you explain how you changed the order in the bios, so as to definitively solve the problem? tks

You are a lifesaver!!! I am a bit new to esxi and my host lost power, after afterwhich two of my VMs would not boot and I did not get a snapshot for them. Thank you so much man, I am not one to reply to old posts but I had to create an account just to say thanks, man.