Fibaro FGS-223 delayed response

Hi,

I have a problem with Fibaro Double Switch FGS-223. Switching works ok but after few triggers, it stops responding for few seconds, usually after 3rd of 4th attampt. I upgraded to the latest 0.67.1 but same problem. Logs shows requests are queuing but there is delayed response. Anyone with the same issue and solution?

2018-04-21 14:12:01.556 Info, Node008, Response RTT 183 Average Response RTT 149
2018-04-21 14:12:01.556 Info, Node008, Received a MultiChannelEncap from node 8, endpoint 2 for Command Class COMMAND_CLASS_METER
2018-04-21 14:12:01.556 Detail, Node008, Refreshed Value: old value=false, new value=false, type=bool
2018-04-21 14:12:01.556 Detail, Node008, Changes to this value are not verified
2018-04-21 14:12:01.556 Info, Node008, Received Meter report from node 8: Power=0.0W
2018-04-21 14:12:01.556 Detail, Node008, Refreshed Value: old value=0.0, new value=0.0, type=decimal
2018-04-21 14:12:01.556 Detail, Node008, Changes to this value are not verified
2018-04-21 14:12:01.556 Detail, Node008, Notification: ValueChanged
2018-04-21 14:12:01.558 Detail, Node008, Notification: ValueChanged
2018-04-21 14:12:02.054 Info, Node008, Value::Set - COMMAND_CLASS_SWITCH_BINARY - Switch - 0 - 2 - True
2018-04-21 14:12:02.054 Info, Node008, SwitchBinary::Set - Setting node 8 to On
2018-04-21 14:12:02.054 Detail, Node008, Setting Encryption Flag on Message For Command Class COMMAND_CLASS_MULTI_INSTANCE/CHANNEL
2018-04-21 14:12:02.054 Detail, Node008, Queuing (Send) MultiChannel Encapsulated (instance=2): SwitchBinaryCmd_Set (Node=8): 0x01, 0x0e, 0x00, 0x13, 0x08, 0x07, 0x60, 0x0d, 0x01, 0x02, 0x25, 0x01, 0xff, 0x25, 0x19, 0x64
2018-04-21 14:12:02.054 Detail, Node008, Setting Encryption Flag on Message For Command Class COMMAND_CLASS_MULTI_INSTANCE/CHANNEL
2018-04-21 14:12:02.054 Detail, Node008, Queuing (Send) MultiChannel Encapsulated (instance=2): SwitchBinaryCmd_Get (Node=8): 0x01, 0x0d, 0x00, 0x13, 0x08, 0x06, 0x60, 0x0d, 0x01, 0x02, 0x25, 0x02, 0x25, 0x1a, 0x99
2018-04-21 14:12:03.492 Info, Node008, Value::Set - COMMAND_CLASS_SWITCH_BINARY - Switch - 0 - 2 - True
2018-04-21 14:12:03.492 Info, Node008, SwitchBinary::Set - Setting node 8 to On
2018-04-21 14:12:03.492 Detail, Node008, Setting Encryption Flag on Message For Command Class COMMAND_CLASS_MULTI_INSTANCE/CHANNEL
2018-04-21 14:12:03.492 Detail, Node008, Queuing (Send) MultiChannel Encapsulated (instance=2): SwitchBinaryCmd_Set (Node=8): 0x01, 0x0e, 0x00, 0x13, 0x08, 0x07, 0x60, 0x0d, 0x01, 0x02, 0x25, 0x01, 0xff, 0x25, 0x1b, 0x66
2018-04-21 14:12:03.492 Detail, Node008, Setting Encryption Flag on Message For Command Class COMMAND_CLASS_MULTI_INSTANCE/CHANNEL
2018-04-21 14:12:03.492 Detail, Node008, Queuing (Send) MultiChannel Encapsulated (instance=2): SwitchBinaryCmd_Get (Node=8): 0x01, 0x0d, 0x00, 0x13, 0x08, 0x06, 0x60, 0x0d, 0x01, 0x02, 0x25, 0x02, 0x25, 0x1c, 0x9f
2018-04-21 14:12:04.224 Info, Node008, Value::Set - COMMAND_CLASS_SWITCH_BINARY - Switch - 0 - 2 - True
2018-04-21 14:12:04.224 Info, Node008, SwitchBinary::Set - Setting node 8 to On
2018-04-21 14:12:04.224 Detail, Node008, Setting Encryption Flag on Message For Command Class COMMAND_CLASS_MULTI_INSTANCE/CHANNEL
2018-04-21 14:12:04.224 Detail, Node008, Queuing (Send) MultiChannel Encapsulated (instance=2): SwitchBinaryCmd_Set (Node=8): 0x01, 0x0e, 0x00, 0x13, 0x08, 0x07, 0x60, 0x0d, 0x01, 0x02, 0x25, 0x01, 0xff, 0x25, 0x1d, 0x60
2018-04-21 14:12:04.224 Detail, Node008, Setting Encryption Flag on Message For Command Class COMMAND_CLASS_MULTI_INSTANCE/CHANNEL
2018-04-21 14:12:04.224 Detail, Node008, Queuing (Send) MultiChannel Encapsulated (instance=2): SwitchBinaryCmd_Get (Node=8): 0x01, 0x0d, 0x00, 0x13, 0x08, 0x06, 0x60, 0x0d, 0x01, 0x02, 0x25, 0x02, 0x25, 0x1e, 0x9d

Did you get anywhere with this?