Fibaro RGBW Controller - tearing my hair out!

Hi folks!

So firstly to summarise what I want to do - I have a large Z-Wave/Home Assistant installation and want to add the Fibaro RGBW Controller into the mix to control outdoor garden lights (LED). I have a simple requirement to turn the lights on/off. No dimming, no fancy RGB colours. Just toggling the lights.

Now I have already done this before 6 months ago with great success. Lights wired in, Fibaro controller working as expected, everything controlled via HA.

However - I had mice chew through the outdoor lighting cable and had to rip up the entire setup and re-wire it. This caused me to reset the Fibaro RGBW Controller.

So my problem now is how to set the Fibaro controller to only switch the outputs on and off. I believe this is controlled through Parameter 14 in the Fibaro RGBW module/Z-Wave control panel, but I just cannot figure out/remember what the value I need to set it to is. I remember researching this in November last year and I found some forum posts with this exact issue and they had the required Parameter 14 value. Now I cannot find it at all!

So I was wondering if someone has the same controller working to do a simple on/off (controlled via Z-Wave, not via the inputs) and what their node configuration is or whether anyone has a way to correctly calculate the parameter 14 value so it is accepted by Home Assistant. The module manual has a table and calculated with the parameter calcs that I need, however I just can’t figure out how to convert the value into something that HA accepts.

Thanks in advance.

How are the lights controlled by HA? Are they zwave too?

The lights are standard 24V garden LED lights. They are wired into the Fibaro RGBW Controller with the intent of controlling these “dumb” lights via HA.

The lights work when powered on with the Fibaro Controller installed so the wiring works. The problem is configuring the Outputs on the Fibaro module to make them act like a simple toggle switch. This requires determining a hex/binary value, which is then translated into an integer that HA can accept. I’ve had several attempts at this with no luck!

Not really a home assistant question then?

Not a very helpful answer/post?

The module and it’s config has been discussed many times on these forums, particularly given that parameter 14 setting is somewhat unique to HA because of the weird/unique way that HA accepts the value for this parameter.

Anyway, I have somewhat solved this myself through trial and error so posting for others to hopefully come across in the future:

  1. It appears that HA does not correctly accept the parameter 14 value for this module under the deprecated Z-Wave integration. It accepts new values, however anything other than the default (4369) gets reset to the default when you refresh the node.

  2. Given #1 - it appears the module is “stuck” in the RGBW mode. What I’ve been doing all this time is trying to “switch off” RGBW mode and just make the outputs act as simple toggle switches, controllable via HA/Z-Wave. This wasn’t working.

  3. So I decided to just go with the flow and rewire the module to have my lights’ neutral (black) wire run to the “R” terminal on the Fibaro rather than “W” as it was before. Voila! Effect was immediate - lights controllable (and even dimmable) from HA. The module clearly still thinks it is in RGBW mode as I have left parameter 14 on default and I still get the colour wheel, etc. It works though!

Perhaps shows my lack of understanding. I understood from your post that this was a fibaro setting that had nothing to do with HA itself. As I say, maybe I misunderstood.

Yes it is a Fibaro setting but one that has some unique interpretation in HA (converting from hex/binary to unsigned or signed integer, etc).

And of course there has been a lot of change in zwave implementation lately