File changes are not kept between reboots

I’m using the latest HomeAssistant OS 64 bit on a Raspberry Pi 4 8g.

I needed to run ‘pip install’, so I run SSH and run it.
After reboot, if I run the same ‘pip install’ command, it reinstalls the package instead of showing that the package is already installed.
Also, I created a file using ssh, and it disappeared after reboot.

How do I make the changes permanent?

Hi! I had a similar issue recently, but it wasn’t limited to just pip install. Anything I did magically disappeared and went back to a previous state. The interesting thing is that when running, all was well - until I rebooted.

In my case, I had a faulty SD card and replacing that card sorted out my problems. My understanding is that it was failing and not actually “writing” to the card, so it appeared that I had updated something, but in reality the changes were not being written to the card itself.

I’d explore trying a new SD card and seeing if this works.

Which is using Linux containers which are - by design - ephemeral. If you want changes to be permanent, use a volume mapped to a directory on the host or a network resource.

1 Like

I’m not familiar with these methods.

Can you please elaborate more about the steps to achieve this?

Thanks a lot!

Unfortunately not. It‘s a parameter that you need to provide when containers get started and I have no clue how Home Assistant OS or supervised work.